Sketch tool and ducks

while working, i observed two things that could be of use::

-i like the sketch tool, i can plan poses, body parts, scenarios, almost anything, the sketch tool overlaps the whole project and sometimes this make hard tracing the sketch with the drawing tools, i think a global “alpha” for the sketch tool below the “Show Sketch” check box in tool options would be of use, you know, only for display purposes, so the sketch becomes transparent in order to keep working without disabling it or deleting it.

-also with some ducks that wont be of use for the rest of the animation, an option to make them invisible or lock them so they can’t be selected would more than welcome, i learned i can “gray” ducks, but the problem is that i keep selecting them, a common problem with this is when moving a capsule layer, i end up selecting the “focus point” and not the “origin duck”

perhaps, is everything i found that can be improved, i’m actually very entertained learning and doing stuff with Synfig Studio, i hope to have something to show soon, saludos!

I can’t select them after convert them to ‘Greyed’. Which Synfig Studio version are you using?

it’s version 0.63.02:


see? i grayed the focus point, but it keeps poping up and i can’t select the origin duck easily

Hmmm, I don’t know why that happens to you because since 0.63.00 the ducks priority when they are at the same place is this:

1st) WidthPoint Position Duck
2nd) Width Duck
3rd) Radius Duck
4th) Tangent Duck
5th) Position Duck

and after that, there is not preference with the other types. As far as I know, Focus duck is a Vertex Duck type so the Origin which is a Position Duck should prevails over the Focus duck.

Are you sure that the Focus parameter is not exactly (0.0, 0.0)?

i am, look:

the grayed duck is barely visible inside the black outline, it raises immediately at trying to select the origin duck, i didn’t knew it was an abnormal behavior.

Can you share the offending file? I want to look.

Sure, but it happens in new projects as well
Synfig Animation 1.sifz (32.2 KB)

I can’t reproduce the problem here. Any of the Paste canvases of your sample file allows to select the Origin duck without Focus duck interference.
I’m using here Ubuntu 10.04 64 bits. I’ll test it with Fedora 32 bits and with Ubuntu 32 bits on a virtual machine. It looks to me like a library problem.

Confirmed. Using Ubuntu 11.04 32 bits reproduces the problem.
I believed that it was a solved issue but looks like it is raising again. See here the story of the issue:

So I’ll keep open the story as open and will work on it when possible.

Meanwhile I only can recommend to hide Vertex ducks (ALT-2) before try to handle the Origins ducks.

thank you, yes, i’m using Ubuntu 11.04, also i sorted it out that way before. greetings and thank you again