sifz-file corrupted :-(

Warnung:    * /media/94FE-05C9/Lotta/5ohm.sifz:<string>:36712: Ebene 'import' wies Wert für Parameter 'filename' zurück

Hi there

Above message is about all that is left from my 10 seconds project. For three hours all went well when suddenly phenomena began:

I’m not sure what started it - either editing waypoints for fading in or changeing the development-machine from vista64-notebook to 11.4-opensuse32?

at first I thought it were my own mistakes but suddenly blend methods I definitely did not use began to appear. lastly, non-keyframes suddenly lacked the background, although it was visible.

Any ideas on that and what’s more - any ideas on repairing the project-file ?
5ohm.sifz (72.2 KB)

I’m not sure, but I think the problem is animation of “blend method”.
Use instead “amount” (0-1)
I’ve tried to correct, but it’s hard. Have you saved some previous files?

unfortunately not - which is not a massive problem because it was just a trial run. I was just curious if there was an easy way to repair the save. thank you for trying to and thanks for the hint - I did lots of blending animation on that trial and would not have suspected that as an issue. what does changeing amount do exactly?

Does it work for capsules as well?

To easy fix the problem you should go one by one to all the layers (paste canvas and any other one) that has animated blend method and right click over it and select “Disconnect”. That will turn it into a constant value.
It is an interesting issue because the behavior of TCB interpolation for an integer value gives a non integer (real) curve.
Also, TCB interpolation produces bounces on interpolation when the values are so close and so different. In this case you’re obtaining weird values for blend method and that’s why the layers complains and turn it into Composite when it is out of range (i.e. negative)

The best thing is not to animate Blend Method and for that you can right click on the blend method and select “Forbid Animation” in the contextual menu. That will make the parameter “static” and not animatable even in animation mode.

I have to turn this behavior (not animatable the blend method) to default for every new created layer from now on. I would include this to the new release.

I’ll try this. Defaulting “Forbid Animation” sounds like a good choice to me. I’ll see into “amounting”


I was able to repair the sifz and it works now - thanks a lot !!

EDIT 2 : looks like color animation has similar problems with tcb : yellow fading in had some blue shadows in some frames due to negative values

EDIT 3 : sifz-file belongs to first edit, not second - I’m not sure it contains the effect described in EDIT 2
5ohm.sifz (41.9 KB)