Shapes not appearing?

i’m new to synfig and animation altogether, so my question might be simple to some people.

I downloaded it yesterday and as soon as I saw it I realized it was much more complicated than I expected (I’m used to using Paint and Moviemaker). So I started playing with it. I had trouble with pretty much everything and was confused by all the layers. After a few hours I had only managed to successfully create a black background.

Later on I noticed that all the shapes I tried to add didn’t appear on the canvas. I tried turning certain layers on and off but that didn’t change anything. Also when I click on the layer with the shape, all of those little “dots” show up (meaning I can move the shape, angle it etc…) but I still can’t actually see it.

Is it not working or is a program like this just too complicated for a beginner? thanks… ._.


Did you read and do the beginners tutorials?

Please check that the default blend method in the Toolbox defaults is nothing but ‘By Layer Default’.
Also check that the default opacity is not set to 0.0.

As wrote Genete, to do the beginner tutorials are imperative if you want to work (and not die trying :laughing: ) with Synfig.

The learning curve of Synfig is very hard. Synfig could seem not very intuitive (it is not) but it has a very powerful options to animating.