Render to AVI/FFMPEG Empty on Windows

Hi all,

I’m completely new to Synfig; I’ve downloaded/installed bought the course and I’m just going through it. Part 3 of the course goes over rendering an animation to video. I have tried following the video directions exactly which is:

Launch the render dialogue, leave all settings at their defaults (target is Auto), and just specify the location of the rendered file adding the .avi extension to the filename.

This reported success and created an AVI file, but the file had no content (just black with no video).

I then tried explicitly setting the target to ffmpeg (H.264 / AVC/ MPEG-4 AVC (Lossless)) and retried the render, but this yielded exactly the same result with the file produced.

The only other thing I tried was to export to png which did successfully produce a number of png images which ran through the animation (so it worked, but it wasn’t the output I was looking for / that the video course directed).

Can anyone suggest what may be going wrong?

I did check that ffmpeg.exe is in the install directory and I ran with the debug console, but there were no errors at the point of render.

The only thing I do see is that, at startup, the following plugins are listed as missing:


I guess the last one could be the culprit, but I don’t understand why any of the plugins are missing. This was a clean install and I also tried uninstalling/reinstalling but got the same problem.

Forum/web searches haven’t yielded any useful information (which suggests it’s uncommon or I’m doing/not doing something too obvious/stupid that no one else has run into it). Anyhow, any advice would be appreciated!

If it helps, I’m running Windows 10 Pro 64-bit and installed from the 64-bit Windows installer

Thanks for looking!

I tried doing the same thing on my Mac. When quicktime attempted to play either AVI or MP4 (though I think the codec is the same in either case based on the tutorial), neither file could be read; quicktime just reported an error.

I tried loading the files using VLC and in that case the videos played successfully. I’m guessing that the defaults just don’t create a file that can be read by the default software on Windows/Mac OS, but it would be good to get other people’s insight on this… based on the course I would have expected the default settings to put something out playable on pretty much any player. Is it just the case that people don’t tend to use these render settings?

windows may not have codec for .avi (for some reason) but try .wmv and change ffmpeg parameters to Windows Media Video 7/8.
This should work, i hope i helped.

I had this problem. When I changed the size of the canvas I was working on it resolved the problem.

Many thanks for the responses and apologies for the delayed reply - I ended up be busy with a load of other stuff and didn’t see the responses until just now. It does seem to just be the default media players on Windows/Mac. The VLC workaround is working fine for now