Render at different size than Canvas without clipping?

So currently there is a bug with rendering at sizes over 750-ish in the height.

My current work-around is to keep my canvas at 1920x1080, but render out to 1280x720 for the moment until the bug is fixed. However, when I specify 1280x720 for the canvas Width and Height in the Render dialogue, it just straight crops the output to that size, rather than scale it to that size like I hoped.

Is there any way to do this? (Other than re-work the entire animation to downscale it, then re-work it again to upscale it when the bug is fixed!)

I just tried with 1.3.11, no problem 1920x1080 to work, 1280x720 to render, both avi and still png

Yeah sorry guys. Now that I think about it, it worked previously, I forgot. And I tried it again and it worked as expected for some reason. But I’m looking at a file right now that represents my previous attempt, and it IS cropped. I just don’t know how it happened. Oh well, moving on. If I can reproduce it I’ll let you know.

Possibly, you accidentally clicked this button? -

That one just locks the ratio though, right? Eg. if it is 1920x1080 and I enter 1280 for the width, it’ll automatically set the height to 720.

No don’t touch it, because your canvas changes but not your content. It has happened to me before.

1 Like

THat button works incorrectly and should be fixed. Anyone can help with creating issue about that? :slight_smile:

Woah, really? That sucks… hahah. Well then, @KonstantinDmitriev, no I didn’t “accidentally” press it, I very “intentionally” pressed it, I just didn’t expect it to be buggy!

I have logged a bug here :slight_smile:

1 Like

Thank you for that! :slight_smile:

The lock ratio just … Locks the ratio
The options for resize/crop are in the tab Other
Not a bug! (See github issue and wiki)


But, for some reason, when I change width/height manually from 480x270 to 1920x1080 - then it resizes.

And when I enable “lock ratio” and change width from 480 to 1920 (height automatically changes to 1080) - then it expands. This is a non-expected behavior. :slight_smile:

1 Like

The problem is that constraints on resize are set in the tab “Other”
The lock is acting only on the ratio of the physical dimensions of the image, to avoid to calculate and type the second dimension.
But the content is defined in logical dimensions (in Synfig Units of 60px).
According how the constraints are set, the result can be resize/crop of the content or even horizontal/vertical stretching.
But the constraints have to be set before any resize operation.

I can see that it works, once you understand how it works, so certainly this is not a bug - but a user interface design issue then? Of course this is a free project and maybe this doesn’t rate highly on the list of things to do, but if simply enabling a certain checkbox by default is the fix, that would solve the issue for pretty much 99% of use cases.