Problem with a Tutorial (Layers-> Blur)

Hi there,

I got a problem with this tutorial:

I did everything (hopefully I did) as it was told in the tutorial, but the last step doesn’t work.
I added the Blur layer and it looked like it should. But then I wanted to change the blend mode from “composite” to “straight”, but that doesn’t work. The properties dialog doesn’t accept the “straight” value. I cannot select it. It is shown in the selection menu, but if I choose it, it is not changed to the value “straight”. It simply keeps the old value. Every other value works fine. Only straight cannot be selected (it can be selected, but it doesn’t change the property value, it jumps back to the old value)

In the black program window (console) there is the following message shown:
synfig(2592) [15:12:25] error: on_editing_done(): Called twice!
synfig(2592) [15:12:25] error: on_value_editing_done(): Called twice!
It is shown until I unsuccessfully selected “straight” and then clicked the blend mode property again.

Another info to this:
when I change the default layer blend mode to straight an than add the blur layer again, it works. But when I change the blend mode of this new layer to composite and than again back to straight, that doen’t work again. :frowning:

What could be the problem with this?

Thx in advance.

This is a bug in Synfig…

There is a solution which Genete suggests in this thread:

“Unfortunately there is a bug in the Blend Method entry that makes impossible to change the Blend method to Stragiht using the drop down method. It seems to happen only to the Blur layer :open_mouth: :frowning:
The workaround is convert the blend method parameter to scale and set the link subparameter to 1.”

Hi rylleman and Tosek, i saw your problem, it’s funny i haven’t noticed this till now, the workaround of Genete is good, i found also a fast way to solve a bit this thing about Blend Method for Blur Layer:

1.- Create a new layer, preferably one with no advanced parameters or ducks like Solid Color layer under ‘Geometry’, set it’s opacity/amount to zero
2.- With Ctrl pressed, select Blur Layer and Solid Color layer and in parameters window, select ‘Blend Method’ and press link from the menu with right-click
3.- Now use the dummy layer (Solid Color Layer) to change the Blend Method

I tried exporting the value, but something i can’t really explain happens, of course all layers using this value can change the Blend method also, but i think is too messy and actually, link from it’s blend method two layers work better, i hope this also have helped.

OK, thanks, it’s working now. Very helpful community here :smiley:

Is that bug now fixed in the new Synfig release?

If you have the “Default By Layer” blend method selected in the defaults of the toolbox, then the new created blur layers will have Straight as its blend method and will work as expected.
The unusual behavior of the drop down blend method selector for the blur layer is still there.