problem drawing a few shapes...

I have only today installed synfig studio on my mandriva 2008.1 laptop. This time i used the rpms given by mandriva whereas last time i had compiled it myself. All this owing to a hardware crash :frowning:

OK, the issue here is that i’m unable to draw several shapes on the canvas. For example, i can use the pencil tool on the canvas but if i try to make a circle, i get nothing.
I am very new to synfig, in fact, this is my first attempt to do anything with it except for installing it. I’m not sure but i think i didnt have this problem when i had compiled it from source.
Please help.

Hi soumen08,
don’t worry, I’m sure it is something very easy to solve.
I assume that you’re using the rpm packages from the links of the download pages. Be sure that you have the latest version they have available.

Did you mean the tool with the “Ink” icon or the tool with the “Pencil” icon? The pencil tool doesn’t create any layer it just draw sketches.
When you use the circle tool, do you click and drag or simply click? Does it creates a new entry in the layer panel but the layer is not visible in the canvas window? What’s the default blend method and the default color you have in the Tool box?

Check this for quick reference:

I used the pencil tool. If i attempt to use the circle, after clicking and dragging, i see some values like radius and center in the lowermost window under the params tab. Everything looks OK,. The foreground is a light pink and the background white (i mean the values on the TAB, on the canvas i see nothing at all). And yes i do see a new layer appear in the layers window. I used mandriva repository packages. The version is 61.09
Please let me know what can be done?

Paste a screenshot of your desktop to understand what’s happening. Also try to save the file and post it here too. I can’t figure it out without a visual feed back.

hi and sorry for the bump, i’m also in the same issue, i have installed Mandriva 2009.1 with KDE4, very cool i must say =D and Synfig up-to-date: my problem is similar, when i use the pen tool (BLine Tool) to draw paths, nothing seems to happen after draw a shape, also if i use the circle tool, as well as the rectangle tool nothing happens, i tried adding the option of draw Bline outline and then the program crashed after shown this message:

In the PDF documentation of begginers, it is mentioned that some laptop users like me and the original poster, could experiment mouse problems due to the touchpad, in my case, the touchpad is not only not shown, all the ports or mouse devices (like 4) are all disabled and every time i wan to enable one of them, it says that feature is not available yet, what in oblivion that means!? also something wise i learned to do is open again the program from the terminal (Konsole) to se what the output is, sometimes it was just thing of some missing library (when lucky) this don’t seem to be the case:

one last thing i checked was for any possible missing library, including Imagemagick, i have all what i think i could need, even Dev packages, but i couldn’t install Synfig for some Library that is actually updated, but still as unsatisfacied library:

Let’s remember that any 3rd party library need is always shown as a dependency for the installation and is download with the program from the repos, so is not likely a missing library at all, any ideas?

BTW, i’m very impressed with Synfig, i saw ‘Prologue’ from the gallery and that was enough for me to look for the solution. and sorry for the size of the images, but they got very blurred when rezised making them illegible and uncomprensible XD.

Hi H13N.H3N,
I don’t have idea what’s happening there because I cannot reproduce the problem (I don’t have Mandriva installed). Maybe you have to ask to the mandriva packager why is it not possible to install synfig. Synfigstudio depends on the libraries installed with synfig IIRC. So it is not strange that you get that: “Layer did not recognize the parameter name” because that part of the code relies on synfig libraries provided by synfig package.

It must explain the problem with the other tools because as well as the parameters are not recognized then synfigstudio cannot provide any render to the screen.


Reading your answer and following my toughs, i decided to download the RPM from Synfig’s Download page, installed and tried:

This time i was able to work fine with circles, paths and squares, perhaps the message from the input devices is a feature that developers might be working on, i’m not worrying for that so much as i don’t have any idea yet of what they do, The problem is actually fault (XD, must blame someone jajaja) of Mandriva packers, but as all is now installed, i don’t think i would face this problem again (even if so, i’ll download again the RPM, not much problem on that) now get back to the Tutorials page, thanks for your support homs =)