please give me a clue, confused

Hi, I’m a new synfig user. I’ve faced a problem, please check the image. When I rotate a layer using rotate layer the layer going pixelated, but if I rotate the shape itself then it is good. Please compare two side, left hand rotates using rotate layer and right hand is shape rotates. What is the matter?


Please, I’ve check it in both linux mint and windows version. I need to know, it is an urgent. Project is on the way.
What is the problem and solution.

In the top menu bar on the canvas you should have a box with a number in it. By default I believe it’s ‘8’. That’s the Quality setting. If you lower the number to 4 or less does it fix the issue? I don’t think that issue will show up when you actually render your animation, it’s only to make working with your animation more or less efficient. But if I’m wrong hopefully someone will correct me. :slight_smile:

No, the problem is on render too. I’ve check that, used 1 instead of 8, in view port it’s looking good but in render it’s showing :frowning:
I’ve used full anti aliased setting too. Don’t know what is the problem.

Would it be possible to post the sif(z) file you’re working with?

It’s not only in one file. Just make a shape(like hand or leg) use rotate layer for rotating the object. You’ll see the problem.

Can you post the rendered file? (not the sifz, the png image)

Are you using the default image size of 480 x 270? I was getting pixilation with that size but it seemed to clear up pretty well with 1280 x 720.

png file I’ve posted here already. In the first post. And rendered size I used 1280 x 720 too.
I think I need to use 1(lower is better as said) in the quality section during render. I’ve checked it, and it almost solve the problem. But not 100%. It creates little blurry image :frowning:

Can you share the sample file (sifz) I would like to confirm the behavior in a windows machine.

If that happens in linux too it should have been cause of many complains. Something is not going well there.

Yes, it is slightly blurred. You can fix that by adding a supersample layer onto the rotated layer in order to cut down the rotation blurring effect.

The sample file includes a Super Sample layer.
BTW, can you distinguish which is the rotated by layer shape without zoom in the rendered image?

See the examples attached.

Rotate Layer does already a super sampling (by pixel) of the context based on the quality value. The best quality seems to still introducing some blurring.

What Super Sample Layer does is to scale up context render size to later scale down to the original size. The scale up to down process eliminates the unwanted blur or excessive aliasing.

rotated.sifz (1.26 KB)

Thanks a lot, great for solving this issue. One question, do I need to apply it on top of the each rotate layer or can I use it just applying on top of the whole character or project?

I would save render time by adding it just over where needed. Adding it on top of the whole project would work too but that would increase the render time more.

It is curious. Try this:

  1. Don’t use the super sample layer.
  2. On each rotated shape (the ones that are under the rotate layer) check off the Anti-aliasing parameter. (Don’t worry on what you see on canvas window, just refer to the render result)

Does it remove the slight blur? I think it does because when you rotate a aliased layer the rotate adds its own anti aliasing effect what gives better result than the standard default.


No, sorry it’s not working.

Ugh, looks like the last suggestion is not a good idea.