OSX - no listimporter

Hello, everybody. I recently installed Synfig Studio on my Mac (iMac 2.8GHz Core 2 Duo, OSX 10.5.8 ) via Fink. Although i’m in the midst of getting acquainted with the program, i’ve noticed a couple of things that aren’t working "as advertised“.

  1. I’m trying to import an image sequence into Synfig Studio (http://synfig.org/wiki/Doc:How_Do_I#Import_a_movie_into_Synfig.3F), but importing the .lst file produces a blank placeholder. Importing a single image does however work correctly (other than regardless of the image’s actual size/ratio it’s imported in at 64px x 64 px – is this normal behaviour?).

Using synfig from the terminal using --listimporter results in…

error: Standard Exception: Document not well-formed. Unable to load 'sequence.lst'. Throwing out job... Nothing to do!
I’ve written Synfig’s Mac maintainer, Hisashi T Fujinaka, about this problem and he replied…

  1. ALT-clicking a color in the Palette Editor does not choose Fill color, but Outline color (same as clicking normally in the Palette Editor).

Any ideas? Thanks in advance.

  1. yes, that sounds like a Synfig issue rather than a Fink package issue. Can you post the sequence.lst file somewhere?

  2. I also see the same behaviour for left-Click and Alt-left-click. Clicking on the middle button, however, does change the fill colour. (see synfig.org/wiki/Doc:Getting_Started ). I’m guessing this is a Mac limitation where you only have 2 (or one?) mouse button?


Sure! It’s this…

FPS 25 VID00047stab1 001.jpg ... VID00047stab1 137.jpg
…located in the same directory as the sequence. For the sake of brevity, i didn’t list the other 135 JPGs on that .lst. :slight_smile: Nevertheless it’s generated by a ls ./*.jpg >> filename.lst as per directions on the wiki.

Confirmed! It does work. I have a Wacom tablet attached with the side button configured for right-click (up) and middle-click (down). I was ALT-clicking instead of middle-click. Thanks!

EDIT: sorry, my mistake. It makes no difference with which mouse button i click on a color, nor with any key sequence plus any mouse-button click – there is no way to select a fill color directly from the Palette Editor. I tried with both the Wacom tablet’s pen and three-button mouse and the Apple optical mouse.

You might try renaming the files so that they don’t have spaces in them. I bet that’s what is tripping the parser up. If that works - file a bug.


Spaces in the names…that’s exactly what the problem was. I substituted an underscore for the space in the filenames and Synfig imported the list no problem.

To note: the parser doesn’t like periods either, as i tried substituting the space with a period without success. But underscores it understands.

Unfortunately, the color picker problem still exists but i’ll put that down to running X on OSX.

Chris, thank you for your help!