objects are scaled undesirably during rotation

For some reason, whenever I try to rotate a non-circle object between keyframes, the object is the same size before and after the action, however it is made smaller everywhere in between (demonstrated in attachment). This is using SynfigStudio version 0.62.01 and is causing me quite a few problems as my animations look very choppy when this scaling happens. :confused:

Method: selecting the many objects that make up the image and rotating all at the same time (prefer not to select each of the 14 objects that make up the overall image and rotate manually)

Aside from that, if I am working while listening to music I get “Fatal IO error 11 (Resource temporarily unavailable)” while doing something such as changing bezier curves or the like :unamused: .

Is there any fix for either problem? (both are really quite inconvenient).

It sounds like you may be rotating the actual object instead of using a rotate layer. I believe that if you rotate the actual object from, say, frame 1 to frame 10, Synfig tries to move the ducks in straight lines on the in-betweens (kind of like a poorly-trained animation assistant). This leads to size changes in your object. The rotate layer, on the other hand, is programed to move things on arcs. Does this address your problem?


As muhkayoh mentioned, basic concept for vector animation is that the parameters are interpolated between its waypoints (linearly or in smooth curve) so you have to always take in mind that the computer doesn’t know what’s the path you’ve followed to rotate or move your object using the Transformation, Rotation, Scale or Mirror tool. For instance, if you select an object’s ducks, and translate them to any other place, the path that you eventually can describe with the mouse from the drag start to the drag drop is not recorded. It just remember the start and drop events.
You actually can see the position curve of any parameter by selecting it and looking into the curves panel. There you can check how does it interpolate based on the waypoints values.

Ah, I wasn’t using a rotation layer (I would have assumed that it was automatic). Well, it looks like I have a nice few hours ahead of me fixing the 20 files I’ve made that exhibit this problem.
Thank-you for your help.