No color ?

Hey !

So, as the subject say, I just can’t put the color on the layer! It’s very annoying ( I tried almost a milion times and it still doesn’t work) because I can draw with the pencil but I can’t fill entire forms…
Maybe it’s just the way I try, or something else, but if somebody can help me… it could be useful !

Thanks a lot :wink:

Hi Lightlink,
I suspect that there is something wrong with the blend method. Something apart than Composite or Straight will need stuff behind to be visible. Can you check what’s your default blend method for new layers in the toolbox? If it doesn’t help, can you share a sample file?

But can you tell me the steps do put the color ?


Do you click “Create Region BLine” option in Tool Option panel?

Maybe you can follow this tutorial:

I did the tutorial but… We’re supposed to have 5 windows. And I just have 4… I think there’s a little problem… It’s maybe because that that I can’t put the colors… so what can i do ? Do I’m suppose to Uninstal the program an instal it again ?

If you’re drawing with the tool that has the pencil symbol, it’s a “sketch,” which is not colorable or animable. It’s useful only for a reference. If you use the Bline tool, you’ll get actual shapes.

Second, if you want to see more windows, you can find all available panels in File > Panels. The “Params” windows is the one where you can set colors.

I had this problem. Every object I drew appeared transparent. I could go into the params window, change the color, change the alpha, change the blend method…nothing. Very very frustrating!

I finally realized it wasn’t me, it was my installation. I reinstalled synfig and now it works fine.

I strongly reccomend that when reporting issues like this, provide the operating system, if you had a previous version already installed and working and the place where you obtained the binaries or the way you have produced them. We don’t give support form untrusted sources of the binaries.