New Head Turning (and Tutorial Update).....?

Hello there, everyone! :smiley:

I was trying to study this “making head turning guide” video tutorial here :
Making headturn guides using Synfig.

But i’m confused lately (not with the guide though, i’m fine with it).
How to make this guide applicable properly in animation ? I mean, like where to put the facial parts like eyes, ears, and stuff, and most important, the facial skin itself. The video itself only shows the way to put in the guide lines but not the face region…?
Or there might be a better way to do it considering Synfig Studio is pretty much updated recently (i wonder).

Also, just a small suggestion. It would be great if someone could put it in tutorial page for easier access because this looks like a really valuable tip.

Cheers :slight_smile:

I think the principles in the head turn are still valid with the current version. I remember testing it myself during one of the earlier release candidates of 1.0. I also think I have a step by step written tutorial laying around somewhere. Just have to find it and see if it still works :unamused: . You can see how an ear and a mouth gets added in the video. I guess it is the same for the rest of the facial features. I would just glue the skin region onto the lines at the end and tweak the vertex and the handles during the turn so that they match the outlines.

You have one? Thanks :smiley: ! Gotta looking forward to it, then. Hopefully so it still works, it’ll add some more variations of making head turns.

Linking should works the same. But in any case, i am a bit worried that it might leads to some confusion (also it takes a bit longer time to do).

I’ll study this video again later on. I just woke up from my night time sleep and still a little bit dozy. :unamused:

done :

Thanks a lot, d.j.a.y!! :smiley:
I’m still learning in this video really hard. I think my head just turned upside-down.
haha, jk :slight_smile:

Oh! I think i get it (hopefully) :bulb:
I think i am supposed to create the guide itself, create a proper face (with its features) and link it to the guides respectively then hide the guide (and disable its render if necessary).
That’s just my assumption and i have to take a break for now. I’ll continue later on. :unamused:

The old head turn with guides tutorial still works in Synfig 1.0. I did not find my written step by step guide, so I will have to rewrite it when I find the time.

Link to the test:

Thank you very much!! I do tried putting the guide lines by myself and understand a little bit more of the old tutorial. Hope you can clear this up even more soon. :smiley:

Also i have other question regarding animation but it has no connection with head turning stuff. Should i add another thread…? :unamused:

Cheers! :slight_smile:

I’m working on something different right now. I’m trying to make an anime-style head turning animation (not-so-smooth frame-by-frame animation). I was thinking of using constant interpolations, but then i realized that using clamped (default) ones with fewer number of frames and small adjustments of FPS might do the trick just fine. :unamused:

Oh, also…
Any idea how to disconnect only one outline’s vertex point from its region?
I can only do it by disconnecting the whole vertexes at once from its region and now i’m kind of stuck (again) :confused:

When you create a region and an outline, what is linked together is the whole list of spline points, so there is not two spline points linked together to split, instead each spline point is the same and unique for both layers.
Maybe you can request that when region and outline are created together, what is liked are the individual spline points created, so that way you can disconnect one of them only.

Thanks Genete!! Will do that later. :slight_smile:

I did a little bit of workaround lately by making an opened spline (with its outline), then making another open spline, but only for the region and linking both vertex points’ ends and both spline’s origins.
Short explanations, i was merging two “C” into one big “O”.

And then another trouble comes (oh boy…) :frowning:
I was trying to hide a group of eye behind the head region by playing around the Z depth parameter, but i tried about an hour and still nothing changes. Even after checking the tutorial (and looked into some scattered files around the forum) i still don’t quite get it :confused: .

Ah, i get it!! :bulb:
The Z depth only works in the same group and will not work in stacked groups. I was making the layer groups like this:

–eye1 (z depth changed)
-head region layer

and nothing changes. So i broke the eyes group apart like this:

-eye1 (z depth changed)
-head region layer

and it worked great finally
A little bit disappointed because i can’t put the eyes in one big group though :unamused: .
I also don’t know what Z Range (and some other ones below) does. Please let me know if anyone do :confused:

Anyway, moving on!! :smiley:

Something like this?:
hide eye group.sifz (2.22 KB)

Yup!! Something like that :slight_smile:
So my assumption was correct then.
I just updated my own latest post about that.
I don’t know why, i always do that every time. Just to avoid posting pointless spam-looking post.
And after i edited it your post pops up in the thread (ouch…)
sorry… :blush:

Thanks a bunch anyway. That’s so helpful :smiley:

Does this help? … in-synfig/


Umm… not exactly what i’m looking for but worth a try. Might be really useful to make a pose switch. :slight_smile:

What i actually mean with my last question is some parameters that i saw at the bottom when you group a number of layers which is the ZRange (along with its Position, Depth, and Blur parameters). I did playing around with them a while ago and i think i quite get it. Still… :question:

And this? … parameters
Does it help?

Maybe it’s worth to take a look/search to the wiki from time to time… :wink:

Well, i guess you’re right. But again, even the tutorial pages needs some more changes.

Okay, back to the topic again. I’m having a really horrible issue right now :frowning:
I took a day off yesterday from studying the anime head turning. And now i was going to start again and trying to load my animation files. Then this happened :open_mouth: :

I really don’t know when. Last time i was playing with Z depth and everything was fine. It even saved the file with no issue.

And the worst part is, i don’t have a proper backup, which means i might have to go back to square one… :cry:

i really need to take a break… (and some help)

I took a bit more inspection to the error message right after posting this and i think i know some of the culprits to this issue :bulb:

The ones that says “width” probably comes from the super sample layer.
I was using two of them in different groups because the “two C’s to one O” trick turns out didn’t end up very smoothly because of this … n_line_bug

And one of the advices was to use the super sample layer and set the width and height parameter to 3x3 or 4x4

For the position ones, it might be the z depth issue, but still no clear yet
And for the rest (side_before, side_after), still have no clue
Also still unable to recover my file yet.
Might update here later. Helps are welcome :unamused:

Have you changed the Synfig Studio version in the middle of the process?
It looks like the saved file format is not compatible with an older version of Synfig.
If on contrary you’re opening a file created with a previous version of Synfig Studio, with a newer version of Synfig Studio it is clearly a bug.
Finally, if you didn’t do any Synfig Studio version change then there are two options:

  1. The file wasn’t properly saved on disk (hard or software faliure)
  2. That Synfig Studio version has a bug that doesn’t allow to open a successfully saved file.

In any case you can always try to edit manually the file by doing this:

  1. Rename your file from “myfile.sifz” to “myfile.sif.tgz” The extension “tgz” tells to the OS that it is a compressed file.
  2. Now use your convenient application to uncompress the file to “myfile.sif”
  3. Then you can edit it on a text editor. It is a XML formatted file so you can edit and fix each section easily.

Search the places where the messages appeared and fix it.

If everything above fails share the file and let someone else repair it.

Good luck!

I haven’t changed its version since trying to making this animation.

Um… I do have a kind-of portable Synfig Studio RC-1. Not exactly portable. I just installed the RC-1, copy the whole folder to other disk and changed the installed version again back to v1. But i never used it. It’s just there in case i accidentally putting the guide in and saved the animation without even knowing it, since in v1 it’s just crashing if the guides moved to anywhere.

Well that might be likely the reason

I don’t know why but it seems either i’m using Windows 8 or it’s just my compressed file extractor software itself got messed up, it extracted my file format from “filename.sif.tgz” to “filename.sif.tar”. I don’t even know if that supposed to happen. :confused:

Anyway, i’ll put the file here if anyone willing to fix it. It actually have 2 png images imported in (both are keyframes) but i decided not to put them in yet. Let me know if they’re necessary as well. :slight_smile:

demo1workaround.sifz (19.8 KB)

Aaah! That’s actually a bug that allows to convert a Width Point list (composite) into a simple plain Width Point list and there is not code written to read such kind of lists. Same happen if you disconnect a Width point from the list. … issues/348

Here is the file fixed.
demo1workaround-fixed.sifz (17.3 KB)

How did I fix it?
Fixed instructions:

  1. Rename your file from “myfile.sifz” to “myfile.sif.gz” The extension “gz” tells to the OS that it is a compressed file.
  2. Now use your convenient application to uncompress the file to “myfile.sif”. Unrar for windows will do the job.
  3. Then you can edit it on a text editor. (Notepad++ is excellent for that) It is a XML formatted file so you can edit and fix each section easily.

What I did was to create a new file with an Advanced Outline and save it as .sif. Then edit it at Notepad++ and search the WPList section. Copy the entire section to your file and it is fixed!

Oh my goodness!!! It opened!! :smiley:
Thank you so much. You saved my day!! :mrgreen:

Oh yes! I did see that when i was playing around with some random outlines and region (different files). I was trying to disconnect the outline’s vertex point from its region from the list by disconnecting them. But it does nothing, and when i double clicked the disconnected vertex point it says some text like “No (something)”. I forgot the whole text reading.

Hmmm… It seems that this bug has been submitted since last 2 years ago, and still no progress on fixing it. Really old bug yet persistent one.
Is there any way to prevent this issue, such as putting warning message then cancels the action or anything :confused: ? (i know nothing about coding, though. Sorry… :cry: )

Yep!! And now it’s really Fixed ^^
This should be in “Advanced Troubleshooting Tutorial” section (if they have one .
.v )

Gotta backup now :::::::… :arrow_right: :unamused: