moving stuff

okay so i watched a simple tutorial on how to use synfig and it showed how to use the BLine tool and how to make it have one point in it that lets you move the whole thing, but the person doing it said that he didn’t think it would work with the shape tools… i am trying to make a person right now but realized all to late that the same process for moving the BLine created objects dosn’t seem to apply to shape created objects. is there somthing i am missing? i relly don’t want to have to delet all my work as i am quite proud of my work and very pleased with the outcome. please let me know if i can fix this or if i have to start over… also if someone could tell me how, or if, you can put shading in one particular place, such as on a persons face, it would be extremly helpfull.

Hi Writer!
Please be patience with me becuase I have some troubles to fully understand your explanations.
I’ll try to explain some concepts that might help you on understand many things.
First, most of the geometry layers have a point (we call it duck) that initially is at the origin of coordinates (the center of the canvas) and its color is green. This duck represents the offset to place the rest of ducks of the layers and then the rendered representation of the layer. It is called Origin and it the is origin of the layer. So for instance, if you consider a region layer, the final position of one of its vertices from the bline is given by this: V*=O+V where V* is the position of the duck in global coordinates, O is the Origin parameter and V is the position of the vertex relative to its origin. So if you move O and make it be different from (0,0) it offsets the whole layer and each geometrical parameters.

So you can animate the Origin of a layer to obtain movement of translation as a solid rigid. But you may want to keep the origin untouched and just move the layer’s bline’s vertices. You can do that in two ways:

  1. Moving the vertices ducks using the Normal tool or any of the transform tools (Rotate, Smooth Move, Scale, etc.)
  2. Using a transform layer: Rotate, Scale or Zoom layer

The first one will give you a punctual shape variation for each frame you add a waypoint for the modified ducks. For instance, if you rotate all the vertices at a certain frame it will be the same result than if you move one by one each duck to that position. So it won’t rotate the layer keeping its shape undeformed. It just will translate the ducks to that value.
The second one is use the layer as a filter. One filter do act over the layers behind it continuously, so if,
for example, you modify the rotation angle of a rotation layer in two different frames, it will effectively rotate the layers behind it around the origin of rotation.

I hope those two hints helps.

the shapes all have the… duck point on them and i can move them each individually but i was hoping there would be some easy way to move the whole thing all at once, or if i will have to move them individually… and i can’t drag select all of them like with the Bline tool and move it all that way… and when i try to ctrl slect all the bits and pices and move them that way it still only moves it a pice at a time

if you want to move all thing at once, you can encapsulate your layers: select all, then click “encapsulate”.
After that, you’ll have a single green duck for the encapsulated canvas.

ok well i just tried to encapsulate everything but it keeps popping up with a thing that says:
Encapsulate Layers ‘Polygon003’, ‘Circle027 Region’, ‘NewBLine007 Region’, ‘NewBLine006 Region’, ‘NewBLine005 Outline’: This layer doesn’t belong to this canvas anymore

am i doing somthing wrong?

Please share the file to understand what’s wrong when you encapsulate the layers. And specify which layers are you trying to encapsulate.
Are you encapsulating all the layers from the same canvas context? (layers aren’t from other subcanvases)

ok here it is… it only the start of a head because thats all i got done before i realized my problem. i hope this uploads right… i havent uploaded anything on here before… let me kow if it dosn’t so i can retry it.
Eric.sifz (1.62 KB)

I can’t find ‘Circle027 Region’ in the file you have shared. Maybe that’s the reason. Try to encapsulate again please.

thats wierd i can’t find that circle ethir… mabey i didn’t save that on there but everthing still seems to be there… i tried to encapsulate it again but know it says this:
Encapsulate Layers ‘Polygon003’, ‘Circle013’, ‘Circle013’, ‘NewBLine007 Outline’, ‘NewBLine006 Outline’, ‘NewBLine005 Region’, ‘Circle011’, ‘Circle011’, ‘Circle012’, ‘Circle012’, ‘Circle010’: get_canvas()!=subcanvas

i have no idea what i am, or am not doing, argh!

Can you tell us where did you download the software? I’m downloading your sample file and encapsulating the layers you mention without any trouble. Please be sure you have downloaded the software from our repository:
Here is the file with the layers encapsulated:
Eric.sifz (2.13 KB)

thank you for encapsulating them for me, but i downloaded the softwear from this site… i don’t know why it wouldn’t work… but thank you so much for all your help, i really appreciate it!

okay well i stil can’t this stuff to encapsulate on my computer so i’m going to delet synfig from my computer and try to reinstall it… mabey there was a screwup when i origonally downloaded it… if it works afterwards i’ll let you know.

How about just try to encapsulate one layer with a new sifz file to see what will happen?

Is this a recipe to reproduce the problem? I don’t understand your question, jcome :slight_smile:

:frowning: have to improve my english

Yes. I remember that when I was totally new in synfig I had the same issue with encasulating layers ,after fight hours I found that my procedure was wrong. So I advised to play with a new file and add just one layer, a circle layer for example, maybe he can then figure out by himself :slight_smile:

There is only one general rule to encapsulate layers: All layers has to belong to the same canvas (or inline canvas). If they belongs to different canvases it fails when encapsulate. Remember that you create an inline canvas when encapsulate so if the layers doesn’t belong to the same canvas possibly some of them will loose the transformations made by the canvas and then the composition could be misaligned.

Hello The Writer,
Like jcome, I had that problem when I began to use Synfig.
Maybe you’re trying to add the layers one by one: in doing that, I too have the same message.
When you already have encapsulated layers, you must reduce them (little arrow to the right, not to the bottom) to encapsulate them again with other layers.

edit : sorry genete, I answered at the same time as you :blush:

:confused: i am a tiny bit confused on what your saying.

jcome… i’m not at all sure what you mean… you lost me… sory… also, just saying, i’m a she… not a he
Genet… what do you mean by “loose the transformations made by the canvas and then the composition could be misaligned.” ?
mad0… which arrow? the next or last frame arows? or the raise or lower layers arrows?

these may all be really stupid questions, but i seriously have no idea what your talking about… honestly the only way i’ve ever made animations in the past was with pivot and power point… nothing this advanced… but that is one reason why i wan’t to learn this. if you happen to have a simpler, posibly dumbed down, way of saying what your trying to tell me then it would be much appreciated… sory.

I could try to simplify it:

if you have three simple layers, A B and C.


You can select B and C, then encapsulate them (call the new layer D, containing B and C).


  • B
  • C

Now you can encapsulate A and D, because they are at the same level. It’s easier to see this if you “close” D:


(B and C are still inside D, but you can’t see them in the list.)

Now select A and D and encapsulate:


  • A
  • D

But you can’t encapsulate A and B, because B is inside D – they are at different levels, and have different parents in the tree.

I hope this helps.

[edited to make example layout clearer and fix bug]

WHOO!!! thank you Andrewkay! yes that makes much more scince. I DID IT! YAY!! THANK YOU SOOOOOOOOOOO MUCH ALL OF YOU FOR HELPING ME FIGURE THIS OUT!! :laughing: