Moving project to Linux (Centos) machine probs with Synfig

I have been trying to move a project I was working on my older machine (Windows) to newer machine usiing Centos - I’m a rabid updater so always the most recent build that day. This is my second attemp at using Synfig, the first attempt was so frustrating I abandoned, and yet I have been unable to find any other suitable software, so I have to get this working for me. Essentially I am animating my choreographies, some of the studies are on youtube and Flickr

I really would like help, and simple step by step if possible.

When at run I enter: Synfig -studio

I get this message and go no further:]

synfig -studio

synfig(6133) [10:35:12 PM] info: Loading modules from /etc/synfig_modules.cfg
synfig: warning: Unable to find module “mod_libavcodec” (file not found)
Nothing to do!

I am looking forward to your reply and am very anxious to get back to work animating and not just troubleshooting the install :wink:

a link to the Chalk Dancers initial work:

There are two binaries with the Synfig package: ‘synfig’ and ‘synfigstudio’. When you write ‘synfig’ you’re calling the command line interface so it is waiting for the input file the output file and some other options. To run the graphical user interface just type ‘synfigstudio’ (without quotes) in your prompt.


I did just that and got:

Could not run the specified command

It seems I still have a problem. I really appreciate you taking the time.

Hi alettames,
As CentOS is a rpm based system you should install the binaries we provide form our website.
Please go here and download the rpm version that matches your arquitecture. If the problems persists please let us know.

Thanks, doing the install right now, I guess you can tell that linux is new to me, thank you for using plain language to walk me through, eventually I will get it, I am not ever going back to doing windows, so I really need to do some learning. Most other forums have drowned me in terminology I am just not ready for yet.

Get back to you when it is done. thanks again.

It did the install, but, left me with these warnings:

  • Updating MIME database in /usr/share/mime…
  • Error in type ‘application/x-opera-extension’
  • (in /usr/share/mime/packages/opera-extension.xml):
  • Unknown field ‘generic-icon’.
  • Error in type ‘application/x-opera-uniteapplication’
  • (in /usr/share/mime/packages/opera-unite-application.xml):
  • Unknown field ‘generic-icon’.
  • Error in type ‘application/x-opera-widgets’
  • (in /usr/share/mime/packages/opera-widget.xml):
  • Unknown field ‘generic-icon’.
  • Error in type ‘application/x-sif’
  • (in /usr/share/mime/packages/synfigstudio.xml):
  • Unknown field ‘generic-icon’.
    Wrote 529 strings at 20 - 2e8c
    Wrote aliases at 2e8c - 3088
    Wrote parents at 3088 - 3aa4
    Wrote literal globs at 3aa4 - 3b00
    Wrote suffix globs at 3b00 - 7318
    Wrote full globs at 7318 - 733c
    Wrote magic at 733c - d228
    Wrote namespace list at d228 - d238

I thought I’d print it here in case it becomes important.

The road is never smooth -

[aletta@localhost ~]$ synfigstudio
synfigstudio: error while loading shared libraries: cannot open shared object file: No such file or directory


using the entries in the application menu did nothing, but the crash monitor started just fine.

You have to wait a bit for our package expert. He will come back in about 5-6 days.
I’m sorry but we have not tested the packages in all the distributions.

googled and found there are some similar questions and answers.
it seems that your system missing libgio, you can try: open a terminal and su to root user and then yum install glib2

hope it help

Followed your direction and came to this:

Reading version lock configuration
Setting up Install Process
Package 1:glib-1.2.10-20.el5.i386 already installed and latest version
Nothing to do
[root@localhost aletta]#

so is there some way to perhaps copy and paste that library to another path/directory ? all or part of it?

Ran a search and found:
in opt/synfig/lib/
Not sure if that helps or just muddies the waters.

GLIB is different than GLIB2, … 1.i386.rpm … 5.i386.rpm

try this:
yum install [size=150]glib2[/size]

tried that:

ing version lock configuration
Setting up Install Process
Package glib2-2.12.3-4.el5_3.1.i386 already installed and latest version
Nothing to do
[root@localhost aletta]#

So still miles to go?

Thanks for all your help.

Hi alettames

Which package did you install? Could you please try the tar one, according to your system (i386) you can choose below one: … 2/download

and just extract it then locate to the bin folder of it, there is a synfigstudio file in it, double click, the Synfig Studio will run if everything is fine.

good luck!

btw, I will try to download centos 6 to test next week.

Originally I downloaded the build CentOs has on it’s repository, when that one had problems, I followed the suggestion on this thread to try the RPM here:

I did download the tar.bz2 as you suggested and extracted the files into a temporary directory. I did click on the Synfigstudio file, but no improvement. Is there s directory it should be copied or moved to?

I have tried re-installing a couple of times but no luck, I could still use the help.

Be patient. I never use centos before, but I will take time to download a copy and try it in virtual machine.

If you can use Fedora instead, it will make you easy since Fedora 15 can run Synfig Studio smoothly :mrgreen:

Yes, unless there’s a particular reason you have to have CentOS I recommend Fedora 15 as well. It’s a great release - even my tablet worked without me having to compile the WizardPen driver - and runs Synfig Studio beautifully.

At this point it is strictly a matter of poverty, I haven’t a sous for anything new, and prospects while on disability don’t come along very often. So for no I will have to muddle along. It runs everything else smoothly enough on my Lenovo.