Mouse pen not drawing


#1

I can use Synfig and draw fine with my Genius wireless tablet mouse but when trying to use the tablet pen mouse it will click on buttons and move the pointer okay but will not draw. I’ve adjusted the pen pressure for the driver but to no effect. I’ve gone into INPUT DEVICES and the pen mouse is listed. Is there a setting somewhere I should try to get it to work? Thank you.


#2

Hi Crankitup,
First of all let us know which version of Synfig Studio are you using, operating system and if other Gtk applications (Gimp, Inkscape) works fine with the same hardware.
It has been reported that in some laptops the input devices produces bad coordinates creation due to that it thinks that you’re using the touch pad instead of the tablet.
Please check the Device Settings dialog and post here all the device names that you can see listed there (using the drop down combo box) and which is its corresponding status (disabled, screen, window)
After that we could give more help.
Thanks


#3

Thanks for quick response. I’m using Synfig V 0.62.00 with Windows XP SP3 with Athlon 64x2 dual core 4200+. My stylus tablet mouse works fine with Microsoft Paint and Artrage but not with GIMP or Inkscape i.e. will move pointer but will not paint or draw at any pressure. My standard tablet mouse and wireless desktop mouse work fine with all applications.
The input device on the drop down combo list is ONLY the stylus mouse. It does not give any other mouse options to select even when I’m using them. I hope this is useful. Thanks.


#4

It seems that it is a GTK installation and device detection related problem.
I’m not a windows user so may be other windows user can help on that.
-G


#5

Crankitup - I don’t know if you’ve seen this thread - viewtopic.php?f=2&t=981&hilit=input+devices
My recipe there works for my Wacom tablet.

Chris


#6

:frowning: Hi Pixelgeek, thanks for the thread and did as suggested but still no joy. I can get the stylus pen mouse barrel buttons to work ok when enabled but the problem is the missing X coordinate marker upon the top line of the root screen. The Y marker moves up and down but I guess I’m not getting any line drawings because it can’t calculate any coordinates. I don’t know why it should only occur with the pen mouse and not any other mouse especially when it is the only one listed in the drop down box. I’ve since tried OpenOffice draw and it works in that and other drawing/painting applications apart from GIMP and Inkscape.
‘Flummuxed’.


#7

It sounds like there is some issue between the GTK API that Gimp, Inkscape and Synfig use and the Genius mouse driver. You might try asking the question on the GTK IRC channel? Or if your Genius mouse has a support email or forum?

Sorry I can’t think of a better suggestion. It works with Wacom tablets…

Chris


#8

It seems that the same or similar issue is being discussed in Gimp maililng list:
archives.free.net.ph/message/201 … c3.es.html
gimpusers.com/forums/gimp-us … -gimp.html

-G


#9

:smiley: The problem with Genius stylus mouse pen not drawing was solved via KYE systems providing me with a driver which makes it work. It is available from download.geniusnet.com/2009/Tablet/Gimp_Beta.zip
I hope other users can benefit from this information.


#10

Thanks for the update!

Chris


#11

I have the same problem with a Vistablet Pen pad. I am using synfig studio 0.62.02. Windows 7 home Premium 64 bit. I also use gimp 2.6.10, I tried the pen pad with gimp and everything works fine without any adjusting of settings within gimp or the pen pad applet. I also have inkscape but have not tried the pen in that.