make point that leave track on some path

Hi, all.
How it possible to make point that leave track behind itself? For example: period of sinus is (invisible traectory) and I want that point start at 0, going to end of traectory leaving track in the shape of a sinus.

Draw the path first, hide then path and reveal it along the time.

Can’t realize how it ‘reveal path along time’. What do you mean? May be I’m not clearly express myself. I want like in attached file. Point 2 is moving on path 1 and in result grows into curve 1 (I separated point from path for clearness) .
Animation1.sifz (2.08 KB)

See attached file:Animation1-2.sifz (2.33 KB)
I did the following steps:

  1. Select the Outline layer and right click ->Make Advanced Outline. This would create an advanced Outline with the same path than the Outline.
  2. Create a Star layer and move its origin somehow near the path.
  3. Select both the Advanced Outline and the Star layer
  4. Ctrl click the Start origin handle and then do right click on the Advanced Outline path->Link to Spline. The Start would move to be aligned to the Advanced Outline.
  5. Reveal width handles by pressing ALT-5
  6. At the Advanced Outline move the first width handle to be at spline start. Then right click the second width handle and choose “Set Side After” and then “Rounded”
  7. Go to the Advanced Outline parameters. Check “Homogenous”. Then expand the Width Point list parameter. Expand the second item and right click the Position subparameter and select “Export” (give it a meaning name)
  8. Go to Library panel and select the exported value node
  9. Go to the Start layer parameters and expand the origin parameter. At the “Amount” subparameter do right click “Connect”
  10. Now animate the origin of the star layer by dragging it along the path.

It is a bit complicated but this is the right way to do it.

Powerfull, it’s really what I need. Was one problem with choosing “Set Side After” in width handle (item 6) that I could not find for a long time . After zooming I found out what was my problem. For next users this handle has 2 “subhandles”, so we need choose “subhandle” in centre.