Make an LST play part-way through an animation?

Hi,

I’m not sure if what I’m doing is viable or not with Synfig; what I’m trying to do is this:

  1. I create an animation with a number of imported images, from frames 0 - 120 (of 170), I move those images around and scale them; this works perfectly fine
  2. At frame 120, I want to flip one of the images over to use a pre-animated sequence (basically something I generated in Inkscape where the original image expands and dissipates like a cloud of coloured gas that is initially concentrated and then expands out so that it’s components are no longer visible). There are 50 images to this dissipation sequence, and so creating an LST and having that drop in to replace the base image at frame 120 seemed to be a great idea (rather than trying to create the effect by hand in Synfig or adding each of the 50 files by hand).

In my case frames 0-120 come out fine as expected. I tried adding the LST as the second element of a switch layer. So from frames 0-120, the base layer is shown, then at frame 120 we switch to the LST which I was hoping would start at its frame 0. What actually happens is that by frame 120, the LST seems to have already played even though it was hidden from view, so all I ever see is the last frame of the LST animation which is practically invisible already).

I’ve tried adjusting the time offset in various ways (setting it to -120f and -50f in addition to 0) for the LST within the Switch layer, but in all cases, I only ever see the last frame of the LST animation sequence.

So my question is: Is what I’m trying to do possible? If it is, can you give me any pointers as to where I’m going wrong? If it isn’t possible, do you know of another way to get the same result?

Thanks all who read this!

Hi!
Changing the Time Offset of the lst file like you discribed should do the trick. At least it worked for me when I tried to recreate your problem.
Can you attach the sif file so people can examine it?
Greetz!

Thanks for getting back to me; I’m afraid it was user error! What I had was:

FPS 24
0 g5213.png
120 g5249.png
121 g5281.png
122 g5297.png
...

This didn’t work, but rereading the wiki page: wiki.synfig.org/Time_Loop_Layer

I changed it to:

MohoSwitch1
FPS 24
png
0 g5213
121 g5249
122 g5281
123 g5297

I hadn’t realised that the MohoSwitch1 was needed (I stupidly thought it was unrelated to the actual task I wanted to perform). Anyhow, it works great now having made that correction :slight_smile: