list file doesn't work

hello,

i’m new to synfig and i’m trying to do a morph animation test.

i put the synfig file, the .jpg files and the list file (a simple text document) all in one folder. i follow the directions that i found in the morphing tutorial in the manual on wiki (the walk cycle one with the four images). i go into the caret menu, layer, new layer, other, import image.

then on the params dialogue i go to filename, find, and select the .lst file.

the file looks like this:

FPS 4

image1.jpg
image2.jpg
image3.jpg
image4.jpg

i think i set everything up correctly, but somehow, nothing shows up on the canvas.

(i also tried the .lst file like this:

FPS 4
image1.jpg
image2.jpg
image3.jpg
image4.jpg

that didn’t work either)

then i close synfig and open it again, and a small window says that it crashed last time and do i want to recover what crashed.

i’m not sure what i’m doing wrong.

any help would be appreciated. synfig looks like a really great program i don’t want to give up on it because of my frustration.

thank you

Hi.

That seems hard! Try importing like this. Carat, file, import. Then find the file.

This has worked for me all the time. Hope this helps.

Hi gdark999,
image files must be on the same path of the lst file or the path inside the lst file must be the proper one to allow directly find the image file (relative or absolute path)
-G

hello eric1223

i tried what you said, but a window pops up saying that it can’t open an image of .txt format. i understand that’s happening b/c the list file isn’t an image, it’s just text. thank you for your help anyway.

:slight_smile:

what do you mean the ‘path’ must be the same? am i supposed to add some extra information to the .lst file?

if you mean the actual location of the image files must match the .lst file, then it does - all of them are in a single folder, along with the synfig file.

please help.

thank you

If you are uploading a text file, I have an idea that might work. You might have to turn the txt file into a image file with Microsoft paint. There might be a print screen button on your keyboard that copys everything on screen if you press it. Then you can paste it on microsoft paint, and edit it from there. :wink:

Are you importing the lst file or opening it?
Are the image file names exactly the same than the ones inside the lst file?
Are the files on the same folder than the lst file?
Can you zip the folder and upload it to somewhere to test it?
-G

eric1223

i’m not sure if you understand what a .lst file is. it’s basically a list of a series of keyframe images that i can upload into synfig. it isn’t actually an image file and i don’t need it to be one. but when i try to upload this list into synfig, it’s not understanding that i’m uploading a specific series of images. i’m trying to figure out why that is.

hello genete,

Are you importing the lst file or opening it?
i go into caret>layers>new layers> other> import image from there.
there are two different things happening
(1)in a brand new, unsaved synfig file, on the params dialogue i click ‘find’ under the filename section. it says . then i select the .lst file. but when i try to set it, i get an error message that says the params couldn’t be set. i tried reinstalling synfig and trying it again, still didn’t work. here’s the error message. “Set Layer Parameter (Import Image):Filename: Set Layer Parameter: Layer did not accept parameter.”
(2) in a saved synfig file, the filename doesn’t say it says, c:/programfiles/synfig/bin. i have no idea why and when i select the list file, it switches back to that filename and i get the same error message.
Are the image file names exactly the same than the ones inside the lst file?
yes
Are the files on the same folder than the lst file?
yes
Can you zip the folder and upload it to somewhere to test it?

maybe eventually. they’re just some really crappy circles in different positions on the image. i think i’ll try to download the walk cycle from the manual and try that one. if it works then it’s something i’m doing wrong.

thank you

A shot in the dark, but does the .lst filename (or path to it) contain any spaces? That may trip up the parser.

Just a thought.

Chris

To avoid any possible bug in the process of setting the filename parameter, instead of create first the Image layer and then modify its filename parameter, do this:
Go to Caret Menu->File->Import and select the lst file. Then look the msdos window to see if it complains with the same message.
If this fails agian try this:

  1. Start Synfig Studio
  2. On the new created empty document add some stuff (i.e. a circle)
  3. Save the document in the same folder than the lst file is.
  4. Close the that document with the dummy stuff (the circle)
  5. Create a new file and go to Caret Menu->File->Import and select the lst file. It should offer the lst file directly because the default folder is now the last one you visited when saved the dummy file.

I hope it works and that as soon as possible we could fix those DOS file path mistakes :blush:
-G

hi genete

i tried what you said, it still doesn’t work. i’m not sure what the problem is. also, when i try to upload just an image, not a list file, the whole image doesn’t show up, even when i change the width, height to the resolution of the image (1024 x 800, for example). maybe i’m changing the wrong values.

plus it keeps crashing every time i try to do something. maybe it’s just my computer, i don’t know.

thank you for all your help anyway. :smiley:

hi chris,

no, there are no spaces at all.