Linux binaries for 0.64.0 (FINAL candidate)


#1

Hi!!
This is the final candidate for 0.64.0.
From now on, the code is frozen and only translations and the new splash screen will be incorporated to this release.
Any development would be moved to 0.64.1, planned ahead.

Those are the changes from the previous candidate:

  • Fixed many strings not updated with the terminology renaming.
  • Fixed: Navigator blinks when scrubbing the timeline.
  • Fixed: Straight blend method fails with alpha < 1.0 in Cairo and tile mode.
  • Fixed: Cubic and Linar sampling fails in CairoSurface. The cubic subsampling still having minor render artifacts on Curve warp layer. On the other hand Warp layer cubic sampling is fine.
  • Fixed: Icon for “Select all Children” not visible when requested over a Group layer from a Set.
  • Fixed: Color correct fails in Cairo

Those are the pending and known issues postponed to 0.64.1:
synfig.org/issues/thebuggeni … 3/search/1

And here are the packages (FINAL CANDIDATES for 0.64.0):

i386:
download.tuxfamily.org/synfig/pa … 8_i386.deb
download.tuxfamily.org/synfig/pa … 8.i386.rpm
download.tuxfamily.org/synfig/pa … 86.tar.bz2

x86_64/amd64:
download.tuxfamily.org/synfig/pa … _amd64.deb
download.tuxfamily.org/synfig/pa … x86_64.rpm
download.tuxfamily.org/synfig/pa … 64.tar.bz2

Please report any new nasty bug as soon as possible to work on it based on its severity.
Enjoy and thanks!!!

-G


#2

Adding a keyframe to logo.sifz at 0,0s cause synfig to hang !

open Synfig
open logo.sifz
add keyframe
bang !

(Cairo ON or OFF)
logo.sifz (4.96 KB)


#3

Confirmed. The Add keyframe button shouldn’t be active if there is not timeline. Do you dare to fix it? :wink:
-G


#4

I want to say yes …


#5

I want to say … it’s done !!! :slight_smile:)))

but seems that KeyframeActionManager::refresh() is not called when time is updated
(caret/properti/time/… /apply)
but when the time bar is scrolled …
at least, my patch eat the crash !

Now hardest part for me … move to git my code contribution in a conventional way !

Edit pull requested… , hope that’s enough conventional, cause i have drafted a tutorial about that in the same time… End Edit


#6

Somes infos about synfig translation :

English (langue source) 100%
Spanish 97%
French 96%
German 92%
English (United Kingdom) 88%
Hungarian 88%
Italian 88%
Chinese (China) 78%
Lithuanian 71%
Russian 71%
Portuguese (Brazil) 65%
Slovak (Slovakia) 49%
Dutch 39%
Catalan 34%
Persian (Iran) 30%
Czech 23%
Japanese (Japan) 10%
Polish (Poland) 10%
Romanian 4%
Norwegian (Norway) 3%
Danish 1%
Greek (Greece) 0%

transifex.com/projects/p/synfig/

see(:ya!


#7

With On ubuntu 10.4.4 32b, Install ok , Launch KO !
(EDIT130506 : You can found a solution further in thread)

[code]synfig studio – starting up application…

synfig(6414) [09:53:25] info: Loading modules from /opt/synfig/etc/synfig_modules.cfg
synfig(6414) [09:53:26] info: Loading plugins from /opt/synfig/share/synfig/plugins
synfig(6414) [09:53:26] info: Loading plugin: add-skeleton-simple
synfig(6414) [09:53:26] info: Loading plugin: view-unhide-all-layers
synfig(6414) [09:53:26] info: Loading plugins from /home/tomato/.synfig/plugins
synfigstudio: symbol lookup error: /opt/synfig/lib/libcairo.so.2: undefined symbol: pixman_image_composite32

[1]+ Exit 127 synfigstudio
[/code]


#8

Ubuntu 10.04 LTS is about to expire. I don’t think we should worry about it.
-G


#9

Dear old computers & ubuntu10.4 users…

To be able to run synfig 0.64.0 in ubuntu10.4 like,
you can update manually libpixman (from 0.16.4 to 0.20.2) by adding temporally (if you don’t want to update the full os) natty (ubuntu 11.04) repository :
deb archive.ubuntu.com/ubuntu/ natty main

old Fedora Synfig 0.64.0 rc same problem :
catalin-festila.blogspot.fr/2013 … -0640.html

same issue in ardour (corrected) :
Ardour 3.0 beta 4 : libcairo/pixman problem
community.ardour.org/node/5203

This trick should work in other distro (fedora/debian/mint/…)

see(:ya!


#10

Source code of Synfig Studio 0.64.0 has been released.
Now building packages!
Stay tunned!
Cheers!
-G


#11

In about box … CopyRight is still 2012 !!! :wink:


#12

Damn! I was in my TODO list: update the copyrights years!
Well, since I haven’t uploaded the tarballs or the packages I can do a commit and rebase the tags.

Thank you!
-G


#13

wiki.synfig.org/wiki/Terminology has been created …

[i]With the release 0.64.0 of Synfig Studio, in May 2013, a new terminology and some icons has been introduced.

Here’s the list of changes:

…[/i]


#14

Warning !!!

look like … BIG PROBLEM adding KeyFrame !!! … (start synfig, add keyframe … crash)
Occur with 0.64.0 (release) commit before copyright year change … will try with last code.


#15

Can’t reproduce here.
-G


#16

last code builded, same result : i can’t add keyframe at all : codedump ! what’s the prob???

building in debug mode now.

(synfigstudio:695): Gdk-CRITICAL **: IA__gdk_gc_new: assertion `drawable != NULL' failed (synfigstudio:695): Gdk-CRITICAL **: IA__gdk_gc_set_rgb_fg_color: assertion `GDK_IS_GC (gc)' failed (synfigstudio:695): GLib-GObject-CRITICAL **: g_object_ref: assertion `G_IS_OBJECT (object)' failed [1]+ Segmentation fault (core dumped) ./synfigstudio


#17

Add KeyFrame Crash :
Have try with older revision, same result. maybe cause of an libs update ?

Version de développement :
Revision: 20130427
Branch: master
Revision ID: 87ed48

Compilé le Apr 28 2013

Compilé avec :
ETL 0.04.15
API Synfig (006000)
Bibliothèque Synfig 47
GTK+ 2.16.6
GNU G++ 4.1.2

Utilise :
Synfig 0.63.05
GTK+ 2.24.10

The crashed program seems to use third-party or local libraries:

/opt/synfig/lib/libMagickWand.so.1.0.0
/opt/synfig/lib/libgtkmm-2.4.so.1.0.30
/opt/synfig/lib/synfig/modules/libmod_gif.so
/opt/synfig/lib/libcairo.so.2.11200.0
/opt/synfig/lib/synfig/modules/libmod_yuv420p.so
/opt/synfig/lib/libgiomm-2.4.so.1.2.0
/opt/synfig/lib/synfig/modules/libmod_dv.so
/opt/synfig/lib/libxml+±2.6.so.2.0.7
/opt/synfig/lib/synfig/modules/libmod_particle.so
/opt/synfig/lib/libpangomm-1.4.so.1.0.30
/opt/synfig/lib/synfig/modules/libmod_bmp.so
/opt/synfig/lib/libcairomm-1.0.so.1.3.0
/opt/synfig/lib/synfig/modules/libmod_filter.so
/opt/synfig/lib/libatkmm-1.6.so.1.0.30
/opt/synfig/lib/synfig/modules/libmod_example.so
/opt/synfig/lib/synfig/modules/liblyr_freetype.so
/opt/synfig/lib/synfig/modules/liblyr_std.so
/opt/synfig/lib/synfig/modules/libmod_svg.so
/opt/synfig/lib/libMagickCore.so.1.0.0
/opt/synfig/lib/synfig/modules/libmod_imagemagick.so
/opt/synfig/lib/synfig/modules/libmod_geometry.so
/opt/synfig/lib/libsynfigapp.so.0.0.0
/opt/synfig/lib/synfig/modules/libmod_jpeg.so
/opt/synfig/lib/synfig/modules/libmod_ffmpeg.so
/opt/synfig/lib/synfig/modules/libmod_ppm.so
/opt/synfig/lib/synfig/modules/libmod_gradient.so
/opt/synfig/lib/libsynfig.so.0.0.0
/opt/synfig/lib/libsigc-2.0.so.0.0.0
/opt/synfig/lib/libglibmm-2.4.so.1.2.0
/opt/synfig/lib/synfig/modules/libmod_magickpp.so
/opt/synfig/lib/libgdkmm-2.4.so.1.0.30
/opt/synfig/lib/libMagick++.so.1.0.0
/opt/synfig/lib/synfig/modules/libmod_png.so
/opt/synfig/lib/synfig/modules/libmod_noise.so


#18

Can you remove any version of installed/build Synfig and start it over from the downloaded binaries?
-G


#19

Uninstalled previous version from synaptic
Remove Sources/synfig/install folder
Installed from binary (0.64…)

same result :frowning: !


#20

Which is your linux distribution and architecture?