Limbs disappeared after moving a layer

I am doing the tutorial (synfig-04-simple-character) in the newest version of Synfig
When I tried to move the arm layer to another part of the list, all of the limbs (except the head and body) disappeared.
Reopening the project did not fix it. Is this a bug?
They are still showing in the list, but not visible, even when I toggle the checkboxes. (but the coloured dots still appear where the limbs should be)

Update: I noticed there is a green folder in the layer folders that disappeared that should just have a PNG in them like the head and body do (the head and body are still visible), but these green folders cannot be deleted, they just reappear after deleting them.

is it possible for you to share the project file? Or a video of the issue so that we can see

“Sorry, new users can not upload attachments.”

How long does this take?

you can upload it on a file hosting site and share the link

Which one will host my project file? (for some reason it only posts as a comment instead of a reply, that’s why I keep deleting comments, it works the second time I click Reply)

I meant use an external file hosting website example: https://easyupload.io

so you would upload the file to the hosting website, then share the link here so that I can download it

This post was flagged by the community and is temporarily hidden.

oh you used images in the project? I won’t be able to see anything without the images that were used

I only followed the official gumroad video course (Lesson 04)
I fixed it by restarting the project, but in the old damaged one (the easyupload link) it got all messed up like that because I tried to move the layers by dragging them (so that it was organized as: Head > Body > Left Arm > Right Arm > Left Leg > Right Leg)
But I did not move it the right way (the arrow buttons) and accidentally put some of the folders or images inside of one or more of the folders which caused the limbs to all disappear (now the head & body).

Ok but I cannot assist you without having access to the images you imported into the project.

This post was flagged by the community and is temporarily hidden.

try deleting all the layers and reimport them by dragging and dropping the images in Synfig

Ok. How you (or Synfig) did it, I don’t know. But the layers are all messed up.

Let me explain some details:
Captura de tela de 2021-05-27 17-15-31
In above picture, you can see two layers named “head.png”:

  • the orange one, whose icon represents a folder with a funnel drawn: it’s a switch group layer.
  • that one with a duck: an import/bitmap layer.

When you import an image, both layers above are automatically created by Synfig Studio.

The Bitmap layer is responsible for the bitmap image draw itself. The image file it draws is defined by Filename parameter, as shown in picture below (I rearranged the panel for a simpler screenshot):
Captura de tela de 2021-05-27 17-20-43

The layer name is irrelevant, but it is by default the image filename.

The Switch Group layer is someway similar to regular Group layer with a important difference: it renders only one of its contents (also called as children layers) at a time.

You can see what children is currently selected to be rendered in three ways:

  • In Layers Panel, it will be highlighted in bold text;
  • In Parameters Panel, the parameter “Active Layer Name”;
  • In Parameters Panel, the parameter “Active Layer Depth”: this parameter only matters if Active Layer Name is blank/empty and Active Layer Depth is greater than or equals to 0.

Captura de tela de 2021-05-27 17-31-07

As you reported, and as can be seen in pictures above, head is ok. But let us see “right leg”:

Captura de tela de 2021-05-27 17-32-19

First problem: there are two layers inside “right leg.png” filter group, so only one of them is shown at a time. The currently selected one is the (empty) Group layer name “hand.png”: it’s in bold text. The not-rendered ones have their names underlined.
You should first change the active layer and then delete the empty group.¹

Now the second problem:
Captura de tela de 2021-05-27 17-36-40

The bitmap layer “right leg.png” is actually referring to file “hand.png” (see Parameters panel).
You should type the current filename there: “right leg.png”.

¹ I noticed a bug: if you try to delete the currently selected layer , an empty group layer will be created o.O So, first, change what layer should be selected to rendering and the delete the useless (and unselected) layer. In this paragraph, “selected” means “selected to be rendered”, “the one in bold text”.

1 Like

@Khemardi

ttps://easyupload.io/m/eff4ip

They are the images from the gumroad tutorial (inside the Workshop > Simple Character 01 folder)

It said “You cannot post a link to that host.” add the h to the beginning of the URL

Now it says “You’ve reached the maximum number of replies a new user can create on their first day. Please wait 22 hours before trying again.”

Amazing

Thanks very much for the detailed support