leaking pixel dots in render with "onto" method

hi – I don’t know if this is a known problem, an unknown problem, or just my ineptitude

I’m rendering a .png file (moon->disc->import image) ONTO a region (moon->disc->moon)

If I view (in the synfigstudio window) it at high resolution and high quality I see extra dots around the edges as shown


In this particular example the dots don’t make it into the actual render (but I may have the settings wrong… I’m very confused about quality/antialias/resolution and how they relate to the sunfigstudio window settings) – but I have seen them in the final render output in the past.

Finally, if I convert ONTO into STRAIGHT ONTO the dots go away.

Thoughts appreciated. thanks.
renderbug.zip (434 KB)

Yes it is a bug. And not the only bug with imagefiles.

I just can see a workaround for the problem meanwhile it is solved:
Swap the positions of the moon layer (region) and the imported image and place them like this:
moon (alpha over)
Imported image (composite)

And set the Invert parameter on the region to be true, to make it a hole. That will render properly at high resolution and high quality.

Thanks for report it.