keyboard shortcut

Hi,

It’s not really a bug, but it’s an awkward problem… why can’t we make our own keyboard shortcut in the settings like Gimp???(if it’s possible, i don’t have found) I use synfig every days and i have a QWERT keyboard and it’s very difficult to use the keyboard shortcut by default. My fingers make some acrobatics figure to use the keyboard shortcut =.=" Can you for the next version, modificated this problem please.

(sorry for my bad english)

Just edit your accelrc file and override the built in short cut by writing your combination there and removing the ‘;’ first to make it enabled.
wiki.synfig.org/wiki/Keyboard_Shortcuts
-G

I just did this myself, transferring all the “alt” commands to “shift+control” so that my alt keys can go back to being third-level choosers (like the option keys on a Mac). Thanks!

Here’s my complete list of alterations:

  • Toggle duck view commands moved from Alt+1~Alt+6 to F1~F6
  • Normal tool moved from Alt+A to Shift+Ctrl+H
  • Sketch tool moved from Alt+D to Shift+Ctrl+N
  • Zoom tool moved from Alt+Z to Shift+Ctrl+I
  • All other Alt+ commands changed to Shift+Ctrl+
  • Decrease/Increase Amount of Layer moved from Ctrl+Alt+( and Ctrl+Alt+) to Ctrl+Y and Ctrl+U respectively
  • Toggle low resolution shortcut added on F7.
  • All low resolution quality shortcuts eliminated, since I don’t need them anyway. (I assigned Ctrl+1~Ctrl+9 at the Gnome level to select between the nine workspaces I have set up, Ctrl+0 to switch between windows and Ctrl+` to mute audio, so Synfig can’t use these commands.)