Jumpy animation

My animation is really jumpy. I have my fps at 24, is it because I haven’t rendered it?

If you are using version 1.3.16, you can enable temporarily the background rendering and wait for the time slider (on timetrack panel) be fully green instead of gray.
Or use the Preview window.