Installed like a charm, opens absolutely nothing 😢

Hi all,

Yesterday I downloaded and installed:

  1. gtk-2.10.11-win32-1
  2. gtkmm-win32-runtime-2.10.11-1
  3. synfig-0.61.09
  4. synfigstudio-0.61.09

and I even found TaskAssign after a little search on the net.

I installed everything in the exact same order as the youtube demonstration video showed but although the installation itself went very smooth, as soon as I try to open a file (any file) it immediately crashes with the message:glibmm-ERROR **: unhandled exception (type std::exception) in signal handler: what:Document not well-formed.

What could be the problem? I would like to use this program as it seems to have a lot of potential but after 2 re-installs I have no idea how to continue.

My computer is a HP compaq 6720s, 2048mb ram, 1,6mhz M dual-core.
I run a (Japanese) windows XP with SP3.

Any advice would be greatly appreciated!

You cannot open any file with synfigstudio, only sif or sifz files. That bug (the crash for bad defined input files) is solved in the last revision. Please use the windows unified install and the core affinity pointed out by pixelgeek in those threads:



Thanks for the quick response.

I meant to say it doesn’t open any bitmap formats like jpeg, bmp, gif.
How can I use it when it doesn’t support these basic graphic file formats?

You can import and export to various bitmap formats. Synfig itself is, however, a vector-based program, with a vector based native file format.


Thank you for the clarification.
I just uninstalled the two GTK and GTKM and installed the latest combined -TEST- installer. Sadly to no avail. One bug resolved another one arises. Still can not seem to .sif and .sifz files. :cry:

You may have to uninstall synfig & synfig studio before installing the test combined installer.

What error do you get when you double click on a sif or sifz file? Are you using XP or Vista?