Importing pictures

I am attempting to import pictures into Synfig, but whenever I import them, they become enlarged, and I don’t know how to revert them back to their original aspect ratio. Does anyone know how to prevent this, or how to fix it after it happens? Thanks.

Go to File->Setup->Misc and uncheck “Scale New Imported Images To Fit Canvas”.

Thanks! I went there, but it was already unchecked. :confused: Any idea for what else might be causing it? I’m just importing a png into a 640x360 window…

What are the dimensions of your png image?

not fully related,

i have done a little rewrite around caret menu/file/import synfig documentation. (up check box size option, add gimp2synfig and svg2synfig links, add .svg and .lst extensions)

You have to change the canvas dimensions for the image to show up properly. It’s a little tricky to explain, but I made a youtube video about it:

Synfig Tutorial 6: Project Dimensions and Basic Masks

I am new also. I cannot get a picture to display. I imported the file in fireworks png or jpg format.I see the file name in layers but no image on the canvas.

The layers box shows z depth, which I don’t understand yet. The png image has 0 zdepth and the jpg image has a zdepth of 1.

The DOS screen says this:

synfigstudio.exe:3640:Gtk-CRITICAL88: gtk_tree_mode1_get_iter: assertion ‘path->depth > 0’ failed

and then says I supposedly moved zero layers and that the rename failed.

Mackeziella> This will not solve everything but … Cairo render (actually) support only png image file format.
So if you have Cairo enabled, at least using software render (if no cairo checked, then software used) will display the jpg image