Imported images dissapear?

Whenever I open an animation I’m working on, all the imported images are gone(well, they’re still there, but they don’t appear on the canvas). Has it happened to anyone? How do I fix that?

Jpeg or PNG images? Accidentally switched on Cairo render while using Jpegs? Several images in one Switch Layer will only show one. Wrong reference link to the filename of the imported file in the Parameters Panel? Images switched off in the Layers Panel? Amount parameter set to 0? Blend Method not set to Composite? Origin of image is of canvas? Another layer on top of it?
Care to share the file so we can have a peek? (but save it as a sfg containerformatfile or the images won’t come along for he ride :slight_smile: )

I don’t know how to upload that on the forum, or where to upload it if it has to be somewhere else
I have both Jpeg and Png, I don’t know how to switch to cairo but I don’t think I did (can you tell me how to check that?) I don’t know what a switch layer is, but there is many copies of the same image. I didn’t change the reference link. The images are not switched off. Amount parameter set to 100. The blend method is not set to composite though, but to straight onto on every images, when I last saved the images were visible, but maybe synfig have some difficulties with that. Origin of image is on canvas. There are layers on top of them, but as they were meant to be textures and were on straight onto it is not because they are hidden behing somethin else.

My version is in french, but there is an error message that roughly translates to
Import layer rejected the value of ‘filenme parameter’

Here it is untranslated if it helps:Le calque ‘import’ a rejeté la valeur du paramètre ‘filename’

Thanks for your help!

Cairo render is under edit/preferences/render but if you don’t know where it is you probably did not switch it on.
Under Save draft/Preview/Submit when you edit a forum message you can find two tabs: options and attachments. Click on attachments and Add files to add the sif file. Make sure you save your file in Synfig as the Containerformatfile .sfg. You can also drag and drop the sfg file you saved right in the message box.

Be sure your image files are referenced correctly in your project.
This error could come from empty name or wrong filename (not found in the path, relative/absolute, maybe bad character).

I think I know what the problem is. My animation is on a usb key but my images are on my computer. It would explain why it doesn’t do that to animations that are direvtly on my pc. Does that makes sense?

It is what I thought…
By default, you load images with full path (X:\folder\file.png)
Try to use relative paths instead (file.png, .\file.png, …\file.png, wherever is is located relatively to your project) :wink: