Imported character not editable


Can anyone help me? I did a character in inkscape, exported as a synfig file (sif) and imported in a synfig project, but when I create keyframes for the character nothing happens. The keyframes are created but they doesn’t record information. I have the animation button on and I have created keyframes manually.

The last time I tried I got this message: The value you are trying to edit is in a composition
which doesn’t seem to be open. Open that composition and you
should be able to edit this value as normal.

What does it means?

It means that you’re modifying a value from a shape that belongs to other sifz file. It is possible because you exported the canvas from a group of your composition, opened the exported canvas in its own window and then saved it with other file name and closed the document window.

Synfig Studio cannot edit a property of a document that has been read from disk if it is not fully opened and has full control (file is locked for modification by third party). Just open the file that it complains the value belongs to, and edit normally.


I did open the other file (is a .sif) but now I can only edit the origin, scale and rotation of the entire character (the keyframes are created). But when I change these values of lower layers like the arm, it changes but no key frame is created.

I built this character on Inkscape (separated by layers), used the"Synfig prepare for export" option, and I exported it as a Synfig animation (.sif). When I import, it shows correctly, with all layers, but like I said only the highest layer of the hierarquy can be animated.

I tried to import the svg file but inside Synfig it’s invisible( inkscape svg) or completly deformed(plain svg).

Look like a nasty bug … but found a “way” to work on it : turn on animation mode in both compositions and you will be able to add some waypoints (do some changes)

I’m sure you will like “Embed layer” from 0.65dev who make the job easier !