Image Resizing Issue

I’m trying to import an image into Synfig, but whenever I do, it’s either upscaled or downscaled, and never is it the same size as the actual image.

For reference, it’s a 16X30px PNG image. I set the animation aspect ratio to 16X90px. When the aspect ratio is much larger, it seems pixel-perfect. Yet when the aspect ratio is that small, it imports and is downscaled to such an extent that I know it’s way too small.

I have tried going into the ‘Layers’ window, right clicking on the layer inside of its parent folder, and selecting ‘Fit Image’ but it’s only ‘worked’ once. I put an emphasis on ‘worked’ because I couldn’t see the exact size of the image.

My question is this: is there any way to see what the attributes/properties/image size of a layer and set them accordingly?

Hello temporarily confused , and welcome here.

I have tested a bit with SyStu 1.0, with a big and little canvas with icons size images, and yeah, look like something have regressed here … can you report it ?

  1. Check if SynfigSutdio , Preferences Dialog, Unit system is pixel.

  2. The imported image is bundled in a switch group layer . Open the group, select the image layer : adjust “top left” and “bottom right” parameters in the Parameters panel.

have fun.

Thank you, d.j.a.y . I have reported the issue per your request. I’d also like to say thank you for what you mentioned concerning exacting the parameters for the image’s size - better than I could have hoped for.