I can only animate one object

When I draw a second object, the previous one disappears, and I can’t find a way to make the underneath layers visible. I can’t even make a background for the circle. (Or find the blend option to change it. I’m such a n00b)

Also, I don’t know how to work with drawn animation. I mean, there isn’t a rubber to change the image. (is spoiled by photoshop overuse) And I can’t find another way to change drawn stuff.

Please someone help me panic

Hi Nimue,
Remember that the layer concept in Synfig is one of the corner stones of the program and is a bit different then the layers of, lets say, the usual image program and each drawing you make is automatically put on its own (new) layer. I suggest you read the getting started section of the manual and experiment with the tutorials and examples. That will save you a lot of frustration later on.
D. (who is sad, cos his dual core fried and is forced to work on his sempron which is to slow for Synfig. :cry: )

I read the tutorial, that’s how I got the circle to move and/or transform in the first place. :slight_smile:
But I still can’t figure out how to make all layers visible. Or, at least, fill the area around the circle with color. The circle has to move over something, right?
Thanks anyway. :slight_smile: I hope I’ll figure it out soon, though, cause I have a small project on it.

May your dual core rest in peace :frowning:

Did you use the rectangle tool to create the black rectangle in the tutorial which acts as the background?
In the layers panel you should then have two layers: one rectangle layer and one circle layer. When you click the layer name then the layer becomes active. When you flag the checkbox next to the name then the layer becomes hidden or visible.

Hi Nimue,
first of all don’t panic :wink:
In Synfig, layers are composited from top to bottom. That means that the on top of the layer’s stack is blend to the layers that are below using the Blend Method parameter of the layer. There are lots of Blend methods and one of them is called “Straight” what means that only the current layer is visible and the context (the layers below) are not visible. Despite that you can not see the utility of that blend method at this moment, the fact is that when you create one layer with the Blend Method to “Straight” it hides all the layers below. So the recipe to solve the problems is:

Select the suspicious layer in the layer stack.
Go to the Parameters Panel and look for the Blend Method.
Change the blend method to “Composite”
Repeat for all suspicious layers.

Also, to prevent that in the future, go to the Toolbox and modify the Default Blend Method for new Layers to “Composite”

IT WORKS! :smiley:

Thanks a million! :smiley:

Ah, yes. Check if the default blend methode of new layers was set to composite…
That was going to be my next suggestion. Really, it was. :smiley: