How to stop looping? Or Converter?

I am a new SYnfig User, I am following all possible tutorials and this forum but i can’t find an answer.
I set linear converter (SUPER THING) to loop background, HOW to pause it on certain keyframe ?

I m trying to do 2 ways

1 - parameters how to set there ? -

I also followed the Wiki Synfig and it was helpful together with these steps Break Time Loop

It is true when I followed those steps i can make pause at certain keyframe and freeze object after,
but and generally when I use TIme Loop i face another issue, around the first Waypoint, objects go rough and ugly, the issue disappears when i make Time Loop invisible.

If i delete the first Waypoint the issue disappears too - together with move of an object :).



would it be possible to be more precise on what you are trying to achieve?
It can be easier to solve a specific problem than a general problem.
Generally speaking, I would say that when working with converters, you express that animation in a mathematical formula instead of individually managing keyframes. So when you want to pause it, you would need to add boolean parameters to check for the time codes, which is arguably harder than just placing some keyframes.

Thank You for the reply.

Yes exactly it’s something I m trying to achieve.

I am trying to stop/pause/turn off the Linear converter of a Group at a certain moment.

I am trying to do it any possible way.

In order to loop I followed this

But instead of moving with mouse, I changed all group to have there linear converter and this is moving my background and exactly for this group i am trying set length.

And from this video i had idea to loop background with linear converter

Thanks for any suggestion.

Ok, I think I understand.

You have your ‘x’ parameter that consist of ‘rate’ and ‘offset’.
With x = rate * time + offset
So you have three parameters to tune: rate, time and offset
rate and offset you can animate using waypoints and keyframes
time you can influence by using the time loop layer

To achieve a stop you can set either time or rate to zero and set the offset to the absolute value the background should have at that moment.

For example stopping at 1 second for 1 second
rate = 10
offset = 0
time = 1s
x = 10*1s+0 = 10
To make it stop (use constant waypoint)
rate = 0
offset = 10
To make it resume at time = 2s
rate = 10 (back to where it was)
offset = -10*(time it was stopped for / 1s)
-> If you have a time loop, this stop would repeat

Super :slight_smile: We are almost there :slight_smile:

I will be really thankful for any possible way :slight_smile: to solve it.

I guess there is a simple trick.

Here, I am trying to stop 216 F for those upper graves. (Later It will be time for the lower)

I hope the screenshots are ok.

Here are the parameters.


The Rate 1. - I can’t change at all. because of that “1” the Graves go from right to

left. even when I change it to 0 when there there is Aniamtiong Mode

it comes back to 1.

I thought It would be enough to change Offset to be there 9. I understand it’s 216 f

position. It just mess up the upper graves and it does not stop.

Ok. Mayby there is even easier solution by using Time Loop Layer

to stop background forever or until specific keyframe.

"The same as changing duration = 0 while in Animation mode and setting it to constant… (the effect of this is pausing the loop on the first frame of the loop = link time)

To keep the object there, I can change link time to a frame where the object is where I want it to be … (same as above, set to constant while animation mode and change link time)"

The steps above they are almost promising. With it I can stop background wherever and how I want. If I delete the 3th waypoint I pause the object forever, if I move the 3 th waypoint on another keyframe, I continue again background from the marked point. Exactly this is what I mean :slight_smile:

I just face another problem (video). Maybe Idea how to solve this issue.

  1. Why, when there is the Time Loop Layer, the upper graves move like

that ?

When I make the time loop invisible the problem disappears, they move again like those below.

I guess it may be related to linear converter

  1. This is exactly what i am trying to achieve, that controlled pause/end if i just get rid of the problem.

Alright, using the Time Loop Layer then.
With the Time Loop, you can leave all converters as is.
The important part is to use the Time Loop correctly.

  1. Set the duration to the length of one cycle of your background loop (i.e. when your background needs 72 frames to loop around: duration = 72f)
  2. For the keyframe you want the loop to stop:
    • set duration to 0
    • set link time to your current time modulus the loop duration (for example, pause at 120f -> 120f mod 72f = 48f -> link time = 48f)
  3. For the frame you want to start it again:
    • set duration back to what it was
    • set link time back to 0
    • add to local time the time you paused (i.e. when you paused for 50 frames, local time = 50)

Everything with constant waypoints of course.
Refer to this file for an example: Background Loop.sifz (2,8 KB)
Hope that solves it

Hej Man it works

It’s exactly i was trying to do SUPER BEER THANK YOU !!!

I have there now only one maybe a new error. In Your case that move is smooth. In my case the move jumps down 1 mm in the point where I stop. Why does it jump down? If I make Time Loop invisible it goes normal smooth.

Again Thank You

Glad I could help.

For the jumping down 1mm I cannot tell you without seeing the file, but my guess would be that you have the start of your row two times in the scene and one is not quite aligned with the other.
I would guess your grave stone row group looks inside like this:

  • Grave Stones
    • [Original Row]
    • [Copy Row]

Check if both groups have (exactly) the same y value

yeap it was the hidden just fool issue :slight_smile:
Sorry for that one and thank You

These issues and solutions should go to the main FAQ,

And by the way I have a new problem with loop and converter.

Let’s say i made different beginning. At 72 F i changed amount from 0 to 1, there i should start to see the graves. and happens so They become visible at 72 f as I set. Then i change the group to linear converter. They start to move from 96 keyframe as I set, Nice, even they start to move smooth. ANd now - Why next to the second waypoint they change speed ? It seems Y and X look fine.

And Now the Time Loop

When I add inside that group the time loop - Why then all the group disappears ?
It becomes visible when the Time Loop it’s invisible. When I set timing for the time loop according to the
tips, Everything is visible again but only there where the Time Loop affects. The group does not appear as i set at 72 f.

Let’s now follow the tips, (THEY are working but i am trying to adapt them to a new situation) The Linear converter starts at 96 F, the time loop should start at the same point. I set the duration. I want to stop it at 216 F. I set duration then 112 F and this time I link time at 96 f. Because it is the starting point.
The Graves appear at 96 already looping. They move with messed up speed
I get 3 waypoints for Link TIme and 3 duration, all them are around 96 F. I delet the 3 th waypoint that belongs to Link TIme and the one that belongs to the Duration time. I check the graves move but with messed up speed… If I remove the 2 first waypoints, the graves are all the time visible and there is nowhere point where they should start to loop.

I set pause, I want to have it at 216. Then I get duration 0 and link time 104 and everything is working as it should.

It pauses but not so smooth.