How to cut a path/connect spline points


#1

I want to cut a path on these two lines. I don’t how to do that, does anyone know? It means that I want to make 2 shapes from this one. So it wouldn’t cover the arm of a character.

basically how to connect these 2 points on one and other side?


#2

there are two ways to do this

  1. Group Layer - case1 - Region alpha over
  • create the front spline’s region by right clicking on an outline layer and select “create region”
  • group that new region and the outline that you want to cut together
  • put the region on top and set it’s blend method to “alpha over”

other way to do this is to copy a region layer, paste in on top of the outline, group them together,
then select both new and old region and link their vertices lists and origins, and set new region’s blending mode to “alpha over”

every move you do in that hand outline will affect its region’s movement as well (they both still linked as one spline)
just don’t move the origin of the group layer, that might gonna mess up everything

  1. Group Layer - case2 - width handle cusps
  • add more width handles (right click on a handle then “insert item and keep shape”)
  • arrange them so it placed at the start and end of the line’s part that you need to cut
  • right click on them and set the cusp types depend on your needs (before or after, and types of each)
    InheritedCut.sifz (5.15 KB)

#3

I am trying to do that. But at the points when I need to set blnd method to alpha over, when I am doind it, synfig is giving me error: “The value you are trying to edit is in a composition which doesn’t seem to be open. Open that composition and you should be able to edit this value as normal.”

So I did opened it, but that didn’t help, the error shows anyway. Wht can I do now?
I am suppose to change blend method of a group right? (in which there are region created from outline, and path)


#4

yes, i got this really late, sorry about it…

i actually tried to replicate your error right away after reading it, but it works fine for me

try to make changes, error shows up,
then open that imported file in a new tab and do the changes again, works fine…

unless, maybe you have more than one imported files? :question: