How to avoid weird distortions when bending with skeleton deformation?

I created a rectangle with the spline tool, and attached it to a Skeleton Deformation layer. However, when bending it, the lines get all weird and it looks generally bad:

Any way to avoid this? Or, better yet, is there a way to set up a skeleton so that it bends the vectors themselves rather than treating it as a bitmap image? (yes, i know i can edit the vectors themselves, but obviously that’d take a lot longer than having some sort of skeleton set up)

1 Like

Your can use a distortion curve

  1. i’m trying to animate an arm, so a skeleton would make more sense. yes, i could break it up into parts and use a normal skeleton, but i want to be able to bend it to make it more flexible

  2. curve warp still treats the object as a bitmap object

  3. it still distorts it

to fix problem with curve warp, turn off fast render on it in parameters panel.

Don’t use curve wrap or skeleton distortion on vectors. Just use a normal skeleton.
See example.bend.sifz (2.03 KB)

1 Like

this worked, thanks for the help!
i initially thought each skeleton bone had to be attached to separate objects but yeah, they can be attached to specific nodes and control a single object that way.

i’ll be sure to keep this in mind too whenever i use the curve warp

you have a tutorial of as use these bones