Hi - ahoj

Hello, i am from Czech (middle europe :wink: and i try to learn Synfig. I’m more than 30 years old, and i have two little children, both boys.
I read lot of tutorials and saw few video tutorials, but my english is not so good and lot of tutorials is made from older versions, and i don’t understand :frowning:. I tried to make a simply animation (red dot) and simply picture with BLine, i can make simply animation with moving Bline, but i cannot make a cut-out animation. I made rotation layer, but it’s moving enything else than i want.
I want make a short video with animate simply horses (short jokes). I think about it, that i will make horse from few BLine areas (legs, body, neck and head), use the cut-out animation for main animation and then use moving Bline for details, can i do it?
This is first experiment with horse:

My Synfig report lot of errors (but it is running) and i can save files only to the root of C:, but nowhere else (i want use disc D:)
My system is Win XP Pro and i instaled the latest stabil version 0.63.05


I guess you have followed the cutout tutorial. Where did you get loose? Can you share a sample file of your trials for this problem?

Yes, cutout animation is not limited to raster images. You can do the animation in two passes. First do the animation of the cutout parts and forget the details. Then in a second pass correct the gaps with vector morphing of the shapes.

Good luck!

Welcome here, dobrý den !

About the documentation hosted in wiki.synfig.org all screenshot are about to be updated with the 0.64.0 venue. So i hope for you (and others…) it will be easier to learn this wonderfully crazy of capacities piece of code… synfig.

Did you try to play with wiki.synfig.org/wiki/Doc:Cut-out_Animation tutorial ? here the pieces to animate are Image Layer , but are layer !
so the way to achieve a cut out , is to place the rotation layer inside a group of layer (encaspul in old <0.64 terminology ) and at the TOP of the group.

If you still need some help about it, can share you .sif to be able to get deeper in your problems.

can’t help you about that…


this is maybe the problem, i look the layers and the whole it is moving is under and what was “on the place” is higher. Thanks! Now how i do the group of layer … i will try it later, children are hungry :wink: i will make a simply picture to test it and i will write here if is it good (maybe post a synfing file is it will be wrong).

It was good way, i used Draw tool, there was three layers from this tool Advanced Outline, Outline and Region, i marked all and made “encapsuled”. When i tried to make a rotate layer, i marked with mouse the name of encapsulate layer, but this is wrong. Now i made rotate layer in the encapsulate (and it is over than three layers) and it is good.
I made few screenshots.
It’s moving

Wrong way


Very thanks for your help :smiley:.
Now i have one more problem. When i made one leg, i moved only with one layer, now they are not together (Green dots are not in one). How can i repair this? With mouse and my hand they are not be exactly in one.

cool to see that you found the way of moving animation !

and here you are :
… where Synfig start to be powerful !

The power of export and connect value in synfig.

and after, you will be very happy to learn about stickman and animating characters :


Hi Misazap

After you animate all the rotate layers to your liking, you can then fine-tune the b-lines my animating the control handles (or ducks - haven’t learnt the current names for these yet: )
So, go to the frame where the lines don’t meet up, and while in animate mode, simply move the lines around so they do:)

Hi, I am back … i don’t make with synfig for a long time. But early and now too i have problem with rendering a video. I tried to search this problem in this forum, but didn’t find anything i want.
When i see prewiew is all right, i see how is the object changing. Then i show the Render settings dialog and try to set parameters … but all i tried was wrong (Synfig is rendering but in player it is not running - player wrote “cannot render video”). Only one (on the picture below, ffmpeg with target parameters “mpeg-4 part 2 (XviD/DivX)”) make a showable video, but it is very bad. There is only few smudges, which are little moving.
Render Settings:

Original object and it is now rendering:
And finally video (sorry for bad quality, i cannot made a printscreen, i had take a photo :frowning: )

What is wrong?