Help Please--Slight animation movement

So, I was doing a slow mow animation (just making a small movement in a large frame of time) and when I preview it, everything looks good right till the end, where the bline does a very small sort of loop. Has anyone had this happen to you before, and, if so, is there a solution? I went through all the waypoints (linear, TCB, constant, linear, they did nothing to change it) and there seems to be no problem there. In fact, there is not waypoint inbetween the two frames I’ve created. Just the starting waypoint and the finishing waypoint . I can’t understand why the bline would have to loop to reach the finish. Any Help?

File will be available if requested.

EDIT: File available. Remember guys, its my first real animation, so bear with me if there are messy blines or waypoints when there should be none. And if you see a quick fix you or I can make, feel free to make it, but make sure you explain what you did. Appreciate the help :slight_smile:
BionicleComic1Scene1.sifz (28.1 KB)

That might help, yes. Forum accepts .sif(z) files posting.
-G

Here is a little more visual one, where you can clearly see what I don’t want happening. The cap does a weird loop to rocket off the screen, when it should just blast off, slo mo, and then rocket off. Explanation and help please?
BionicleComic1Scene1.sifz (27.1 KB)

The canister and the cap should move during the slow movement with a linear interpolation waypoint. If you use TCB it would interpolate considering the next and past =http://synfig.org/wiki/Waypointwaypoints and will produce that bounce.

-G

Put the waypoints before on out as linear and during as full linear. Worked perfectly. Thanks for the help Genete. I’ll be sure to put up my animation sometime in either the works in progress section or the finished projects section, if I decide to finish the whole thing before releasing it. Anyway, thanks for the help.

Please lock this thread, or do whatever you do to finished topics. :slight_smile:

Thanks to you for using Synfig!
Anyway there is a thread in the feature request forum that raises the same problem one and other time for professional animators even. It is needed a new interpolation method that acts smartely on those situations.
-G

You might also consider animating the origin of the ‘cap’ canvas rather than animating the vertices of the region and outlines directly. I’ll probably save you a lot of headache if you want to tweak things later.

Yeah, I realized that. Actually, I’m doing both the origin and the vertices now for other layers that I have. When I was planning this whole thing out, I realized that a lot of parts would need individual moving. The cap, as you well pointed out, does not.

Any other tips?

EDIT: Would you suggest I encapsulate my other background layers? I don’t like how they are right now, very messy/unorganized, but naming them would be to big a hassle too.

And for Inkscape imports. Is there a way so that synfig does not immediately translate the whole pic into tiny blines and layers, or will it automatically do that? Becuase right now, my computer starts to take forever to respond, and on windows, it can be somewhat fragile saving after every single edit :slight_smile:

Yes, I’m a big fan of encapsulating. For instance the cliffs and all the details on it would be easy to encapsulate because you’re not going to animate the details separately. It save you from having to scroll up and down the layers list too :slight_smile:
As for importing, the other option is to import the background as a bitmap or raster image format. It keeps it simpler, but you lose the ‘resolution independence’ of being able to scale a vector image to any resolution you want.

Chris

Alrighty guys, I am back with a slight problem.

With animating practically finished, I turn it into a .gif file and check it out. Unfortunately, something is wrong.
When looked at, the dark spot on the ground starts getting particalized or something (its hard to explain) and his eyes become really sparky.
Here is the link:
http://www.brickshelf.com/gallery/abcde13/BionicleComics/bioniclecomic1scene1.gif
*Render specs: Quality: 1 , extension: .gif , time: 0 to 50 seconds

I like to keep it here along with other lego stuff, so I don’t use youtube, or vimeo or such.
You may have to let it load the animation and do a run through before it does it smoothly.

Ignore the text box showing through, I realized the amount for it started going negative, and fixed that in this attachment.
Hope you guys know what’s going on, because I sure don’t.

Oh yes, and I encapsulated the background stuff, pixelgeek
BionicleComic1Scene1.sifz (203 KB)

This is due to a bug in the renderer for gif-images. Change to using Imagemagick or Magick++ as renderer as this should solve it.
Please do a search on this forum for more info. (gif + artifacts)

Thanks, rendering with imagemagick. Thanks for the quick reply as well.

Okay, rendered in imagemagick. No help, because when opened in chrome or IE, , nothing comes up. Any other advice?

Imagemagick will produce same artifacts. Use magick++
-G

magick ++ is not a target option for me. Only imagemagick is. and when rendering with magick++, what should my file type be?(be saved as?)

magic++ and .gif are the options.
Latest windows and linux binaries from official website do bundle the magick++ libraries IIRC.
-G

Wait, so lemme get this straight. I render with imagemagick, and save the file as .magick++ ? Or am I doing something wrong?
And do I have to have imagemagick installed as well?

You have to render with magick++ as renderer target and use .gif as file extension. Please be sure that you have and are running the latest stable version form our download repository: synfig.org/cms/en/download/stable

Sorry for not be clear enough the first time.
-G

Thanks, but maybe I’m not being clear enough too. I have the latest stable version for Windows (mine is Vista).

By magick++ as render target, do you mean I use imagemagick? Because I only have imagemagick as a render target, not magick++. Are you sure the magick++ option is only available in the Linux release?

Thanks for helping me though. It has been someone frustrating, given that it has taken me 3 days of rendering and still no success. :frowning:

So I think there’s couple of things you’re missing here.

  1. Genete’s leading you astray. We don’t have support for magick++ under windows. This is a limitation of the build environment under windows.
  2. If you want to use ImageMagick as a target, you’ll have install that separately. You’re probably getting a 0kB size file because Synfig is trying to use the convert.exe that comes with ImageMagick but is instead finding the convert.exe that comes with Windows and converts your harddrive from FAT to NTFS, and is failing because it’s passing invalid parameters.

Your best bet may be to render to a series of PNG files then use another program to assemble them into a GIF file.

Rgds,
Chris