Flower Tutorial Help

Ok, so I’ve recently downloaded Synfig. I have a basic understanding of Flash and Photoshop, so I understood all the concepts behind BLines and all that. I was just going through the tutorials to get familiar with the new software when I ran into a problem. It was at the first animation part of the flower. I added the 2 vertecies to make the bud and then looked back through the animation to see if it worked like the tutorial. It didnt. In the tutorial, at any time in between the beginning keyframe and 4.5s, the two added points were not visible but still affected the image. In my animation, the 2 new points are still visible and unmoving, creating a very messed up animation. How can I fix this to look like the tutorial? I’ve done this four times to see if I had just misread and even had someone else do it with me. I followed the tutorial word for word and its still not working.
Flower at 5s.JPG
Their flower at 2s.JPG
Flower at 2s.JPG

I see what’s going on here.
Open up the vertices list in the Params panel.
Find one of the the new vertices and at the frame just before the one where you want it to be visible and take effect, right click and choose “Mark Activepoint to “Off””
Repeat for the second vertex.
Now it should work again.

Yes I tried that, because its the next part of the tutorial. But it ends up creating this weird snapping motion at the last second. When I mark the activepoints as off the points do not affect the overall animation at all until they come on again, and when they do they cause the animation to jump in a very unsmooth manner to compensate the new points and tangents. But in the tutorial, you can see that even though the points aren’t visible, they are still forming the bud shape.

I had the same problem. Next to each vertex that I created for the bud, there’s a locked icon in the params. In the tutorial it says “DYN” for dynamic. Does that have something to do with it? Is there a way to unlock them? I had the same issue with turning them off hid the ducks completely. I remember this working really easily when I tried it a couple of years ago. Is there something new that has been added to the program that wasn’t updated in the tutorial. Any help would be greatly appreciated.

Thanks a bunch!!!


There is a problem with this tutorial - exactly the same thing happened to me when I tried it. Something seems to have changed in Synfig Studio since it was written because a number of people who did the tutorial before me had no problems but lots of people are hitting the same problem now.

If I get a chance I’ll try going through it again to see if I can work out what’s happening.

When a parameter has the word “DYN” (old version) or a chain icon (new version) it means that the parameter value is shared with other parameter of same or other layer. So, changing one of the shared will change all the others. This happens when selecting two parameters and choose the “Link” action from the contextual menu.
For your curiosity: Internally in the Synfig code those parameters that are linked are called “Dynamic Parameters” so that’s the reason for the DYN word. Later, in 0.63.00 IIRC, it was introduced the chain icon with the meaning of “linked”.

You can disconnect any parameter from its shared value by right clicking it and selecting “Disconnect”. It will disconnect the parameter from the shared value and would create a new constant value only for the right clicked parameter. The rest of linked parameters will remain linked. Beware that Disconnect will loose the animation it might have too.

Yes, the tutorial needs some review.


Ok, I’ll redo the tutorial strictly following the steps described in it and check if there is something wrong or something has changed since the version it was written.
I’ll post here the results.

Hi guys!
You’re absolutely right about complain on not be able to perform the tutorial. The On/Off logic was broken after I fix one bug related to on/off status.
I apologize for the inconveniences and it will be fixed as soon as possible.


Thanks so much for looking into this Genete! You are absolutely wonderful. I was just assuming it was an error on my part or I accidentally turned something off. You’re the best!