Error "unable to create file for [...]: permission denied"

First of all, hello everyone!
I’m just starting to use Synfig on Windows XP and I’m also new in this forum.
I was trying to render my first animation: I tried to get a .gif output, but I got the message

“unable to create file for [address of the file]: permission denied”

Note that I was creating the .gif file in the same folder of the corresponding .sifz file, the target field was set to .gif, and that I got the same problem also with the .png output (the file is created, but nothing is visualized when I try to open it).
Maybe it’s a trivial problem, but as a beginner-level user I couldn’t figure out the solution.
Thanks for any help you can give me.

Hi C-aesar,
Can you paste the string that you replaced as [address of the file] in the message?
The first reason I can imagine is that you think that it uses the same folder than where the file was created, but for some reason it is using a system folder (where you don’t have write rights).

Hi Genete, and thanks for helping me!
The string is
C:\Documents and Settings\yo\Documenti\knight_rider.gif
Probably the location of the file is part of the problem, because I moved to the desktop and it works! However, the problem remains if I try to work in the Document folder!

When you render to a output file check that you can navigate to the desired path by clicking on the “Choose folder” button from the render dialog.


Yes, I can…but the problem is always there. It seems that the problem is just with the document folder and its sub-folders.

Windows path handling is very special and maybe we have problems with space characters.

Thank you for the help Genete!
The support on the forum is another good reason to use Synfig!