Drawing problem

Installed Synfig on Windows 7… is there a problem with the OS? I have been trying to use it to draw a simple object and nothing comes up - won’t fill or draw any object… it seems it is not actually creating the layer…any suggestions?

I know it worked on Win7 Release candidate. I haven’t installed on the final version of Windows 7 yet though.

Some questions -
Do you have the same problem for all the tools? Circle, gradient, etc?
Is the layer created but you can’t see it? Or no layer at all? (I’m wondering if your mouse clicks are not registering in the canvas)
Are you using a tablet?
I’m assuming you’re using version 0.62.00?


I had a similar problem in Linux. I installed the latest release candidate on Linux Mint. The only way I can draw on the canvas is if I disable the input device. A layer would show up in the Layer Dialog but nothing on the Canvas.

Once i disable the mouse, then i can draw with the mouse. (the same thing with a tablet). I didn’t have any problems with the '09 release.

Please tell me exactly which “release candidate” did you install? Are you talking about the snapshots? It is supposed that the input devices problem is solved in the last snapshot version.
Also, if you had installed previously another version of Synfig Studio, it will keep the input device settings inless you erase the .synfig folder in your personal home folder, so if the wrong input device was enabled then it will continue enabled. Please install the latest snapshot for your system and delete or rename your .synfig folder in your personal home folder. it should disable automatically any other device than the core pointer. Later you can select any specific device in your system it it works. Core pointer always should work fine for everyone.

I am new here - greetings to all.
I have installed the latest version of synfig (06300) - and I havbe the same problem - no strokes nothing.
I have Win 7 64 bit.
edit: In Administrator mode - it works - but confused.

Greetings rave.
Please follow this thread to see if it helps.

Thank you for the link - I will read and try it.