Detached Bline

Note: This may be a minor error but it’s bound to screw up your entire project, forcing you to start over. Or just delete the layer.

Been working on the Animate mode, and I admit this hasn’t happened before while I worked, but adding a tangent in Animate Mode and moving it around (at somewhere 2s) detached the bline at 0s, giving me undesired results no mater where I move it around. It shows on the preview too. May be a critical bug so I thought I’d toss this there.

I’ve supplied both the screenshot and the file for further analysis.

By tushantin at 2010-11-06
1-3.sifz (66.7 KB)

Hi tushantin,
Can you give a step by step recipe to produce this problem starting from scratch. It would help to narrow the cause of the problem.
Thank you very much.

It’s very difficult to reproduce this error actually (found this the hard way). Deleting the layer and redoing it “exactly as before” still doesn’t reproduce this error, which is good when you’re working on a project but bad for bugfixing. But I’ll throw it out there if it’s any help.

  • 24fps
  • Make a shape with limited blines (somewhere between 4 to 6 segments)
  • Go to Animate Mode
  • Change shapes every three frames as you like
  • Add a couple of extra segments while still in animate mode between 1s to 2s 9f, backtrack back to 1s slowly to see any new-segment anomalies and fix them. Most of the time it works well, but if you’re lucky (or unlucky) you’ll see the Bline’s detached and you can’t do a thing to fix it. Even if you delete the bline it seems to fix on one frame, but the problem’s still there in the rest.

The bug is perfectly reproducible.

The added point in animation mode produces a “On” waypoint and a new item in the bline (which is a expected behavior) but strangely the bline doesn’t take it account when the time cursor is back in time. At certain frame back in time it discards the added point and renders the bline like if the new point never existed.

I’ll add a new item in the bug tracker. Thanks for take the time to report the recipe.


You’re welcome! :mrgreen: Just hope this gets fixed soon. Thanks for your time.

Just curious. Has the bug been fixed?

Not yet :frowning:

I’ve had this problem crop up as well, so it’s not an isolated incident.

I’m running Windows 7, if that’s relevant.