Cut-out animation

i’m trying to create a cut-out animation, using ur instructions in the cut-out tutorial, Genete.

i thought i did everything in the tutorial…imported all the body parts of my character, created rotate layers, exported all the amounts…but it still doesn’t appear to set up the way i want it to be…the way it should be!! :frowning:

so could u please have a look at it, genete? i think it might be something wrong with the composition…maybe the origins of the rotate layers, or the layer order.

Here’s the file:

mediafire.com/file/m2iixze5yy

Thanks in advance! :slight_smile:

P.S. also the program keeps crashing, when i try zooming in, so i can view the kusari layer better (i’ve got a zoom layer in the file, and have got it set to -1, but the image is a little too far way. i need like a value between -1 and 0, because 0 is too big, and -1 is too small!).

mediafire says the file isn’t there…

Can you describe what is not happening and what is actually happening?

G.

That’s what I obtain when I click on the link. Can you test it again please?
And before you load the file again take this in consideration:
The image files are not stored in the sifz file. The sifz file just keeps the relative path to the image files.
If you have modified the image files (modify its dimensions) I can not use the ninja parts from the other thread because the composition would not fit.
The best way to share a composition like that is to place all the image files in the same folder than the sifz and make a zipped file with the sifz and the image files. Then upload the zipped file to mediafire and place the link here.
If you don’t know how to make a zipped file please ask here.
Regarding to the zoom crash I’ll reply in the other post.
Cheers!!!
-G
(notice the amount of ‘!’ I’ve written. That’s for your enjoyment :wink:)

hmm…that’s STRANGE!!! :confused: i’ll try it again, after making a zip file, like Genete said, with all the image files that i was using in the project!!!

Cheers!!!

(^that one’s for YOU, genete! :smiley: )

hmm…that IS the right URL path…i just went to mediafire to make sure…strange that the link doesn’t work!!! :confused:

and about the zoom crash…sorry, Genete, but this one’s a little bit different than the one i posted about in the other thread!!! :wink:

i’ll try to get back to u with all the info u requested on this one, AND the other one!!! might take a little while though…

Cheers!!! :smiley:

well…i’m having a difficult time trying to figure out how to describe it!!! :blush: that’s the reason why i uploaded the file in the first place…so Genete, and whoever else, more suitable for the task can have a look at it, and tell me what’s wrong!!!

Cheers!!! :wink:

I can’t access that link either.

The zoom layer accepts values between -1 and 0. Try -0.8 .

ok, cool!! thanks, pixelgeek!!!

and about that link…i’m sorry!! i don’t know what the problem is!!! that’s the link mediafire gave me for the file!!! :confused:

ALL RIGHT!!! :slight_smile:

Genete…gerco…here’s the link!! hope it works!!! :unamused:

i created a zip file, like u requested, Genete, and uploaded it…both the sifz and the images that i used for my project r included this time, although i don’t QUITE understand why u needed the images, since if the sifz file TRULY does not store the images, like u said, how could it retain all the editing that i did to them, without messing up the image files that it gets the path to? :confused: i’m CONFUSED!!!

anyway, hope it works!!!

mediafire.com/?olnvtjjdlzj

When you import an image file into a document it stores the relative path to where the file is. The image files that are linked in your document are referred to other folder, in particular:

…\Ninja Image Parts\

So, if you want to share the image files and the sifz files with the path to them correctly stored in the sifz file to allow anyone to open and see the images, you should re-link the image files from the same folder than the sifz file is, in order to any other user don not need to recreate the folder structure you have created (i.e. …\Ninja Image Parts)

BUT DON’T DO THAT, I’LL DO IT FOR YOU. Next time you do a new project store the images in the same folder than the sifz file and load them into the new sifz from that place.
Now I’ll study your file and I’ll let you know what was happening.
-G

If you read my tutorial (unfortunately that advise is at the end…) it says:

That means that if you do it you break the rotation thing. That’s your case. The images were aligned by using the Translate parameter of the encapsulate layer (that is, you moved the origin of the encapsulated) so the rotation layers copied doesn’t share the same origin what causes rotation break…

To solve this you should:

  1. Set the Origin parameter of the encapsulate layers to be (0.0, 0.0) in all the encapsulated.
  2. Re align the images by moving both of the corners of the image at the same time (CRTL-A (select all corners) and drag with the mouse).
  3. Delete all the rotate layers except one of each type (hips, arm, leg, etc.). Realign them in the proper place, and then duplicate them again (copy, paste) into the proper places as described in the tutorial.

Try it by your self.

-G

EDIT: Stupid twin…

ok, Genete :exclamation: i’ll remember to do that next time, and i’ll also remember to look at all the basic tutorials, like u said :exclamation: (some of them i already read…) :wink:

Thanks again :exclamation:

By this comment I assumed that you followed the steps I described in the previous post and that it worked.
Please do this:

-G

EDIT: Removing all of my twin’s posts…

here’s the latest file: mediafire.com/?mfybjczgw2u

Hope u can figure out what the problem is :exclamation:

-C

:wink:

I’ve looked into the file you posted in the wiki (the second post) and I haven’t looked to the file that you have posted in the last post of this thread.

I would like YOU try to do the steps I recomended in the previous posts.

The reason for that is that you learn the concepts and not just get the solution. Because if not, next time you will end with the same problems again.

So I’ll explain you in an abstract mode what did you do and what you should do to restore it.

An encapsulate layer (the expandable one with the triangles in the left and which its icon is a brown box opened) acts like folders. They holds layers inside and the layers that are inside are like stacked in a separate heap.
Rotation layers rotates EVERY layer that is below it untill the scope of the rotate layer.

So if you have this configuration:

Encap1

Rotate layer1
Layer 1
Layer 2
Encap2
Rotate layer2
Layer a
Layer b

The Rotate layer1 only rotates the layers Layer 1 and Layer 2. Encap2 and its children are not affected due to the fact that the rotation effect ends at the end of the scope of Encap1

On the other hand the tutorial tells you to create a rotation layer for each joint and duplicate it to place on each encapsulated limb. But what happen if each encapsulated limp has a different reference position? The relative rotation origin is wrong then.

You moved encap1, encap2 etc. to align the images. Don’t do that!. You have to realign them all to be its Origin parameter at (0.0,0.0) to allow the duplicated rotation layers have the same reference!

So that’s the reason for the first step.

Do it! and you’ll see how the ninja parts are broken. Don’t worry.

Now, one by one, realign them by moving both corners at the same time:

Do it! and you’ll have the ninja images prepared to be rotated properly.

Now delete all the rotate layers and left only one for each rotation. PLACE THEM IN THE PROPER PLACE AND AFTER THAT COPY/PASTE IN EACH RIGHT ENCAPSULATED LAYER. They will stay in the same place (because the encaps are all aligned)

it must work.

I can say it louder but not clearer.
-G

EDIT: Too many emoticons in this post. It looked way too stupid…