Curve Warp et al


#1

Guys? Has Curve Warp changed in Synfig Studio 1.2.2 under Win10 64bit? Is it my system? Am I just cursed when it comes to Synfig?
If I open up SS1.2.1, Curve Warp acts like the wiki says. If I open it in SS1.2.2 or 1.3.10(had it lying about), nothing happens to the lower imported png layer even when the Curve Warp layer is enabled, and, If I take the two layers out of a group, the canvas goes blank!(That is,to chequerboard). Spherize does the same and maybe Twirl - Synfig Studio just crashed when I tried to test it on inserting a vector rectangle beneath. As usual, a 20 minute job is still here after a whole day of trying, analysing the limits of the problem, trying other versions, trying to do the simple bit with greenscreen and importing it into a video editor etc etc etc

Of course, I can’t get SS1.2.1 to stay stable enough to run through the five second clip I want to make because it collapses on something else - I want a tight zoom and it’s too much for the poor thing. Zoom… Crash!

SAL


#2

You know what… I feel your pain. Especially with zoom-to-crash thing. It seems that Synfig doesn’t like it much, although I got better results when I did zoom with ‘Stretch’ layer instead of ‘Scale’/‘Group Transformation’.

As for ‘Curve Warp’, it appears to be working fine.
Can you provide an example file?

P.S. If there’re a lot of distortion (or even blur) layers in your work such as ‘Curve Warp’, ‘Spherize’ and ‘Twirl’, I would recommend you to use 1.0.2 version — it handles those a bit better and, in some cases, faster because it uses old rendering engine which is more stable than new one.


#3

Hi hi Svarov
thank you for getting back. I’m only using one curve warp (basic wingflap not, not elegant, was supposed to be a 20 minute job :smiley: ) and then tried to move and zoom the whole thing with the layer controls.
[Edit: If I enable curve warp it clears the canvas but produces a result when I go to preview. Skeleton Deformation seems to work ok though. doesn’t clear the screen doesn’t clear the canvas, makes the images below, vector or raster, deform as per spec]
I shall give the thing a try again later - kids’n’stuff - and see if things work anyway after a re-re-reboot (you never know). I shall try the stretch layer thing while I am there.

Wow 1.0.2? will I RECOGNISE the controls? :smiley:
Thanks again
SAL

  1. List item

#4

Here you are, I hope you can see it. Link to test file and it’s got everything you need.

I started all over with one image one vector shape and a curve warp layer on 1.2.1 so it’s clear and clean as anything.
SAL


#5

When I loaded your project, png image is not there despite you saved it in container format (sfg). Maybe something wrong with handling spaces in path to file? I remember something like this was causing problems long time ago.

Can you try the following:

  1. Create a directory structure without spaces, something like this: C:\Projects\Raven.
  2. Copy your png file to the above path, also removing spaces from the filename itself, e.g. full path will look like this: C:\Projects\Raven\Raven.png.
  3. From your current project remove all ‘Switch’ layers and standalone ‘Image’ layers with the old image.
  4. Import back the image from the new path (File->Import).
  5. Save to sifz (not sfg), restart the program and see if problem is gone now.

#6

Hi Svarov
Not a coffee bean. I trimmed the test to one image (no group) and a Curve Warp right above. Just like always, a blank canvas when I enable the Warp. And you’re so right! My container doesn’t contain anything! Soz for not noticing (and I only had the one pinot grigio I swear.)
See?

If I render a test frame you can see the curve warp has worked but that isn’t any good for the users!

But look at this. I noticed it recently (I’m using 1.2.2 but only paid attention when it showed up on 1.2.1 and I totally could have sworn it wasn’t there before).

Think I’ve got a screwed up lib or something that might be causing trouble with both versions?

SAL


#7

@LinuxLass: Your images can’t be displayed from your Wordpress, and direct access give
image


#8

oh hoots
I’m on it!!

Soz - boss has been on at me for ages to get a bit of a site and I finally gave up!


#9

Go Go Go!


#10

Well, you sure have some weird kind of problem…
I also have Windows 10 64 bit and Synfig 1.2.2, so I tried to reproduce your issue with Curve Warp you attached, but it works for me.

Your guess about broken libraries might be the case, of course.
There’s a standalone Synfig 1.2.2 archive here: https://www.fosshub.com/Synfig.html
Download ‘Synfig 64-bit Portable’, extract it in a separate folder, run synfigstudio.bat from the extracted archive and see if it fixes your problem (chances are small though).


#11

Hi Svarov, thanks a stack!:heart_eyes:
Downloading now and I shall have a look in a bit.
Thank you again for keeping me in mind
SAL


#12

Here we go holding thumbsssss…

BOTHER. No joy. I AM sorry coz I loved this idea. Still showing up the symbol-funny instead of degree. I will kidnap hubby’s laptop and give the thng a try there but he is a bit antsy bout that sort of thing (hardware guy, bless :smiley:)


#13

Could you please try this in order to remove the strange characters: https://github.com/synfig/synfig/issues/667#issuecomment-452240944
It seems it is related to the font

Replace the content of c:\Program Files\Synfig\share\gtk-3.0\settings.ini with

[Settings]
gtk-theme-name=Adwaita
gtk-icon-theme-name=Adwaita
gtk-cursor-theme-name=Adwaita
gtk-button-images=1
gtk-xft-antialias=1
gtk-xft-rgba = rgb
gtk-font-name = Sans 8

#14

Lovely! Droid Sans changed to Sans and my degree symbols are all back where they should be :sparkling_heart::sparkling_heart::sparkling_heart:

Thank you for sorting me out Bob Synfig :star_struck:

SAL


#15

Hi Svarov,
I’m on a sicky today but awake enough to try Synfig so I downloaded
SynfigStudio-1.3.11-testing-19.02.09-win64-9583a and the Curve Warp layer works for me on this version. Don’t know if that helps anything with anything for you but it helps me coz I need to warp a curve
SAL
EDIT
hoy how LONG does it take to render 145 frames at 24fps??? :cry::cry::cry:


#16

Ah, nice to hear that you’ve got it working. It’s always good to check the latest development releases from time to time. Stuff gets fixed there :wink:

Heh, I was rendering my 38 seconds long animation (24 FPS, FullHD) for a two whole days, so yeah, it can take some time… I heard BobSynfig implemented a progress bar so at least you can see now how mush is left.

P.S. Get better there, friend :slight_smile:


#17

Thank you hon just a cold really but it’s been going around you know?
Boss had it last rotten last week so I can feel ill without being guilty:star_struck:

I did a test render that was like seconds but the one I wanted never stopped and it’s like two twirl layers over a png. Biggish file yes 5000x5000pixel to FHD but did Synfig get that bad it won’t handle rendering that size?? No progress on the bar even if pressing play does the job when you’re testing.
Today maybe I will try shrinking everything down just to see.

[REPORT BACK]
Size seems to be an issue.
I scaled everything down to default screen size and a titchy png and it renders at least. Skeleton deformation went crazy, but “one step forward, one in a different direction.”