CPU Full and GPU 0%

I’m very annoyed because I’m on ubuntu20.04 with an asus core i5 (8 CPUs) and a GeForce GTX 1650 graphics card, but when I use synfig, only one CPU is used at 100% and the GPU at 0%.
I had version 1.4.0 appimage. I recompiled from the source code, nothing helped. When I want to move a key on the timeline for example, Synfigstudio stays blocked for several minutes before updating the display.
In short, it’s difficult to work under these conditions.
Does anyone have an idea for a resolution?
Thank you in advance

Translated with www.DeepL.com/Translator (free version)


Synfig doesn’t support GPU rendering at the moment, so eating up CPU is expected. And multi-threading only works when background rendering is active:

Not much you can do. How complex is your scene? If it has a lot of distortions/blurs in it then it can cause a significant slow down.

Actually, it is used when rendering a single frame too. But it depends on scene elements/layers.

Ah, ok…
It is indeed very present on a sequence with a time loop and a blur layer…
But I have the impression that multithreading is not optimal because I always have a CPU which is very busy (and not the others) with the background rendering…

Another question, I can set up FFMPEG with nvenc, for example with cinelerra-GG.
Why can’t I access it with the command line
synfig "montage.sifz" -t ffmpeg -o slide2.mp4 --fps 25 --start-time 0f --end-time 902f --video-codec h264_nvenc


I just checked the code, and currently it is limited to embedded options :frowning:
I’ll try to fix it.

Wouah that’s great! cool!

That’s interesting. Can you clarify a bit? I have ‘Background rendering’ disabled and I never saw Synfig using more than 1 core to render a single frame. What are requirements to make it work?

On my side, when I do a background rendering, I always have one CPU at 100%. The others seem to be used, but not in the same proportions.

@Svarov it depends on layer types involved.

Example: Blur layer

  • It isn’t optimized / ported to the Cobra engine
  • All layers below it need to be rendered before it works, but they may be rendered in different threads

As Micar said, it may be an uneven distribution: the main rendering thread eats the most part of CPU load. I’m not an expert to work on it now :frowning: