Change Synfig GUI Font in Win 8.1 / DPI related


I found some thread about a problem of display of “big” GUI font under Windows.
I use a font size of 100% (default is 125% in Windows 8/8.1)
The same problem was described in GUI Font
It is DPI settings related (see Bug report #53 - Large font in GTK theme shifting Params list)
Darkspace65 proposed a solution to make the font smoother (Smoother font in synfig on windows 7) but it not changing the size of the font.

Go and edit this file:
C:\Program Files\Synfig\share\gtk-3.0\settings.ini
add the line:
gtk-font-name=sans 8

Default font
With “sans 8”
Beware don’t abuse! (20). Almost all the the widget would change of size too.
This setting would be useful for some tests with the GUI.

Hoping this will help the ones affected by this “bug” :smiley:

Very nice! Your solution works under Windows 10 too. As does mine, so now I don’t only have a smooth font, I also have a larger one. Me and my eyes thank you! 8)

I found another “fact” about the problem of display.
Checking the properties of GTK3/Adwaita on Linux, I found that the default font used is Droid Sans 10.
Of course it is missing on Windows by default :laughing:

So download Font Pack from this site (Direct Link)
Unzip an double-click on the .ttf files to install them
Edit C:\Program Files\Synfig\share\gtk-3.0\settings.ini
Modify or add the line:
gtk-font-name=Droid Sans 8

It will look a lot better :wink:

Good catch! Can you open an issue on it. If thnik that could be fixed upstream. Droid Sans is licenced under Apache and could be blunded near synfig : “if not droid into system font, then copy droid to local font”.

hop hop … . … d969e7d151