Can't render to mpg or avi - worked around

I can not render my animation to avi or mpg: (using Open SuSe 10.3)

user-linux:~> synfig -o test.avi /home/user/anim.sifz
synfig: warning: Unable to find module “mod_magickpp” ( cannot open shared object file: No such file or catalog)
synfig(5496) [03:08:03] info: target name not specified - using libav
Output #0, avi, to ‘test.avi’:
Stream #0.0: Video: mpeg4 (hq), yuv420p, 480x270, q=2-31, 925 kb/s, 24.00 tb©
synfig: symbol lookup error: /usr/lib/synfig/modules/ undefined symbol: img_convert

What am I doing wrong? :frowning:

See these links:


Unfortunately there were not any participants in the developer challenge.

You should be able to work around this problem by doing this:

synfig -t ffmpeg -o test.avi /home/user/anim.sifz

This uses the ffmpeg target, which runs the ffmpeg command-line program instead of using the ffmpeg libraries.

I will try that!
Just wanted to tell you that I changed from Gnome to KDE windowmanager and then everthing worked fine!