Cant Compile!

I am on Mandriva Linux 2008 Spring and since there is no package i tried to compile. When I configure ETL it succeeds and then on attempting to make it says

nothing to do

so it does not install ETL and without that i cant install much else. why is this happening? please help!

Please post some more information, was there any output before that error? Can you attach the config.log?

BTW, Mandriva has a contrib repository, you might want to work on getting synfig into there: … .2Fcontrib

well ETL configures cleanly. if you want a copy of the output text when configuring ETL let me know. make output looks like
Making all in ETL
make[1]: Entering directory /home/soumen/softcompile/ETL-0.04.12/ETL' make all-am make[2]: Entering directory/home/soumen/softcompile/ETL-0.04.12/ETL’
make[2]: Leaving directory /home/soumen/softcompile/ETL-0.04.12/ETL' make[1]: Leaving directory/home/soumen/softcompile/ETL-0.04.12/ETL’
Making all in test
make[1]: Entering directory /home/soumen/softcompile/ETL-0.04.12/test' make[1]: Nothing to be done forall’.
make[1]: Leaving directory /home/soumen/softcompile/ETL-0.04.12/test' make[1]: Entering directory/home/soumen/softcompile/ETL-0.04.12’
make[1]: Nothing to be done for all-am'. make[1]: Leaving directory/home/soumen/softcompile/ETL-0.04.12’

that is all surprisingly uninformative.

cant upload a .LOG file?? it says extension not allowed.

It seems like you’re saying you did a

make all

in the ETL directory. This is not needed for ETL. Only a

make install


Is that correct?


no i just ran a

in the hope of running a make install at some time

ok so i just have to do a make install? nice ill try that and let you know.

Im intrested in packaging synfig for mandriva but i dont know how. if u can help ill do it!


well i did a make install and it didnt report any errors and apparently was done since i can see files in /usr/local/include with the names make install showed when installing for example there was gaussian.h etc…

now when i tried to compile synfig it exited with the error that it needs ETL and while checking it failed.

I did ./configure --help and then i couldnt find a way to tell it where to look for ETL. I need further help…


Well ./configure uses pkgconfig to find ETL. So, you need to set the pkgconfig path, and later you need synfig to be in your normal execution path. So you need to do the following (in you case):

export PREFIX="/usr/local" export PKG_CONFIG_PATH="$PKG_CONFIG_PATH:$PREFIX/lib/pkgconfig" export PATH="$PATH:$PREFIX/bin"

assuming the ETL.pc file is in “/usr/local/lib/pkgconfig”. And assuming synfig and synfigstudio end up in “/usr/local/bin”.


Ive finally managed to compile and install the software on my comp. many thanks to the forums… :smiley:
Now something i am intrested in is to make an rpm out of this so that other mandriva users dont have to go through compiling it from source on their machines. If someone can help we could make an rpm package out of this.