Building Synfig on Mac using Homebrew…

Hi! I was wanting to ask a question about building Synfig with Homebrew on an iMac (late 2009, 27-in.) computer. My computer is up to date with the OS (10.7.2) and has the latest version of Xcode side-by-side with Xcode 3.2.6 for Snow Leopard. Here is my issue. In fact I will show it to you what I got from “brew doctor”:

brew doctor

Your gcc 4.2.x version is older than the recommended version. It may be advisable
to upgrade to the latest release of Xcode.

Some folders in /usr/local/share/man aren’t writable.
This can happen if you “sudo make install” software that isn’t managed
by Homebrew. If a brew tries to add locale information to one of these
folders, then the install will fail during the link step.
You should probably chown them:


==> /usr/bin occurs before /usr/local/bin
This means that system-provided programs will be used instead of those
provided by Homebrew. This is an issue if you eg. brew installed Python.

Consider editing your .bashrc to put:
ahead of /usr/bin in your $PATH.
==> You have uncommitted modifications to Homebrew’s core.
Unless you know what you are doing, you should: git reset --hard

I am still a newbie to all this stuff with Homebrew, so please bear with me. I have never needed to chown something before. Also, do you have an example of what a .bashrc would look like? Homebrew suggests I should consider editing it. I know I can write one myself with a text editor, but I never have had any experience in doing so.

I am also assuming that there may be a conflict in between the two versions of Xcode that may be causing my install problem. Could that be so? Homebrew is not recognizing that I have Xcode 4, so I think the path is still in the Xcode 3.2.6 folder and keeping me from compiling “synfigstudio” correctly. The “synfig” install was done flawlessly, but I can’t seem to make install “synfigstudio”. I have also tried the git reset --hard option to no avail. Does anyone have any advice on this?

Thanks for any and all assistance. :slight_smile:

Unfortunately there is not enough people that can help you on this issues. Please be patience between one Mac user gives you some help.


I am having trouble installing Synfig on OSX. The simple installer dont work and I hav tried to install via Homebrew also but I got trouble there also, maybe related to yours. I got this error at the end after running brew doctor.

Error: Failed executing: make install
If `brew doctor’ does not help diagnose the issue, please report the bug: … -new-issue
msgr-00-estet-bild:~ mathias$ brew doctor
We couldn’t detect gcc 4.2.x. Some formulae require this compiler.
NOTE: Versions of XCode newer than 4.2 don’t include gcc 4.2.x.

Seems like Synfig needs gcc 4.2.x and its no longer included in Xcode. How can one solve this problem?

I understand that keeping all the platforms up to date is a big job but I hope that it is possible to solve this.