Build help for Fedora Core 6


I’m trying to build synfig from source on FC6 (the package I found won’t install because of a problem with rpmlib, so I thought ‘straight from source’ would be simpler).

I’ve downloaded, configured, maked and make installed ETL 4.11 from the sourceforge link. But when I come back to configure synfig I end up with this:

checking for ETL >= 0.04.11… configure: error: ** You need to install the ETL (version 0.04.11 or greater).

*Answered this partially by using:
export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig as suggested…
it now recognises the ETL

Now stuck on:
checking for libxml+±2.6… checking for libxml+±1.0… configure: error: ** You need to install libxml++, either verison 2.6 or 1.0.

libxml++ for FC6 is currently 2.14 ish, will that work and what do I have to change? I’ve downgraded the package:

[root@pepi synfig-0.61.08]# rpm -q libxml++

still doesn’t configure. Giving up for the moment…

Is there a simple answer, has anyone got a working build on Fedora (preferably 6)?

Thanks in advance, Hugh

I’m not Fedora user but I’ll try to give you some hints:

  1. Do the export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig before configure or install anything:
  1. Be sure that you install the development version of each package:

Try again and don’t give up!
Good luck


First of all, thanks for your help. I’ve downloaded synfig-0.61.08-r2030,
done the export before anything else and started the ./configure. Same result:

checking for ETL >= 0.04.11… yes
checking ETL_CFLAGS… -I/usr/local/include
checking ETL_LIBS… -lpthread
checking for libxml+±2.6… checking for libxml+±1.0… configure: error: ** You need to install libxml++, either verison 2.6 or 1.0.
[root@pepi synfig-0.61.08-r2030]# rpm -q libxml++

I think I’m stuck now, not many options for libxml++ around and I prefer packages, because it’s tidier.

If I modify the config script, is that likely to work? If so, just replace 2.6 with 2.6.1-1.fc2 ?! Nope, just done that, doesn’t work.

Also, just tried libxml++ from source (rather than packaged in rpm) and, of course, that gives a pile of dependencies.

Also tried: export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH
before doing anything, at start of session. No joy.

Just to give you background, I’m in the east end of London and do some charity work. I think I can find some kids that would love this, if I can get it going…(I’d rather not configure a box specially, because I haven’t got another one, currently!).

Best regards Hugh

Firstly, FC 6 is no longer supported (security or otherwise), so it is strongly advisable to upgrade to FC9. Alternatively choose a distro that releases less often and does security support for longer. Examples include RHEL, CentOS, Debian or Ubuntu LTS.

Secondly, did you install the -devel package for libxml++ ?

If so, what does rpm -ql libxml+±devel say?

It should have this file in it:


Ok, understood for FC6, never have time for upgrades, got to make some, I guess…also, sorry, I misunderstood, I was thinking about synfig development branch rather than the libraries.

Got synfig itself compiled:

  1. PKG_CONFIG_PATH=/usr/local/lib/pkgconfig
  2. ETL from source tar.gz, untar and make
  3. yum install libxml+±devel
  4. yum install gtkmm24-docs
  5. synfig-0.61.08-r2030 configures and makes, not tested yet, loads…

Then problems with synfigstudio-0.61.08, configures OK, but when making:

This looks like some configure options might be useful? Made some progress anyway, thanks. I suspect this is going to run slowly on this box, but I can always repeat on the next, once the method is clear…

Best regards Hugh

Can you check if the logo.sif file is there? /tmp/synfigstudio-0.61.08/images
If so, what we don’t understand is the message about the “stripes” the logo.sif file hasn’t got any stripes gradient…
please do manually the following commands after building synfig successfully :

cd /tmp/synfigstudio-0.61.08/images synfig -q installer_logo.sif -o installer_logo.png --time 0

and paste here the output.

Another thing:

can you write here all the commands you did (or can do) for a new fresh build? I would like to be sure what are the pre commands you made before configure synfigstudio.

Good luck

Hi, not much time today to work on this, but:

I’ve just looked in images and installer_logo.sif is there…do I need to compile one of the mentioned libraries into synfig? How?

For the builds I just used ./configure , make, make install , thought I’d start with something simple (although the image magick looks ‘useful’).

Best regards Hugh

You forgot to enter the images directory before running the synfig command and also to check if logo.sif is in the images directory.

Oops, sorry, here we are:

Hmmm, maybe you have an older version of synfig in your $PATH that cannot build logo.sif.

Try this command:

which synfig

Is it the same as where you installed synfig?

Also, have you modified logo.sif at all?

No don’t think so, first go at synfig:

[root@pepi ~]# which synfig /usr/local/bin/synfig [root@pepi ~]# ls -al /usr/local/bin/synfig -rwxr-xr-x 1 root root 112547 Jul 20 11:28 /usr/local/bin/synfig

Also, no I haven’t touched any of the files…I’m using a lot of your time, so if there isn’t an ‘easy’ answer, we can off-line this for some time until we have a newer box (may be a while though)…

Best regards Hugh

Didn’t answer this question fully, here’s the output, which is just form ./configure, no options. Configure status for synfigstudio:

[code]Synfig Studio v.0.61.08
Configuration Summary

Install Prefix -------------------> /usr/local
Host Platform --------------------> i686-pc-linux-gnu
Icon Format ----------------------> png
Debug Mode -----------------------> no
Profiling Mode -------------------> no
Optimizations --------------------> 2
Window System --------------------> gtkmm
FMOD Enabled ---------------------> no

$CXX ------------------------------> ‘g++’
$CXXFLAGS -------------------------> ’ -DNDEBUG -Wno-deprecated -O2 -W -Wall’
$LDFLAGS --------------------------> ‘’
$SYNFIG_CFLAGS ---------------------> '-I/usr/local/include/synfig-0.0 -I/usr/local/include -I/usr/include/libxml+±2.6 -I/usr/include/sigc+±2.0 -I/usr/lib/sigc+±2.0/include -I/usr/include/libxml2 -I/usr/include/glibmm-2.4 -I/usr/lib/glibmm-2.4/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include ’
$SYNFIG_LIBS -----------------------> '-L/usr/local/lib -L/lib -lsynfig -lxml+±2.6 -lxml2 -lglibmm-2.4 -lgobject-2.0 -lglib-2.0 -lpthread -lsigc-2.0 ’
$GTKMM_CFLAGS ---------------------> '-pthread -I/usr/local/include/pango-1.0 -I/usr/include/gtkmm-2.4 -I/usr/lib/gtkmm-2.4/include -I/usr/include/glibmm-2.4 -I/usr/lib/glibmm-2.4/include -I/usr/include/gdkmm-2.4 -I/usr/lib/gdkmm-2.4/include -I/usr/include/pangomm-1.4 -I/usr/include/atkmm-1.6 -I/usr/include/gtk-2.0 -I/usr/include/sigc+±2.0 -I/usr/lib/sigc+±2.0/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/lib/gtk-2.0/include -I/usr/include/cairomm-1.0 -I/usr/include/pango-1.0 -I/usr/include/cairo -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/atk-1.0 ’
$GTKMM_LIBS -----------------------> '-pthread -L/usr/local/lib -L/lib -lgtkmm-2.4 -lgdkmm-2.4 -latkmm-1.6 -lgtk-x11-2.0 -lpangomm-1.4 -lcairomm-1.0 -lglibmm-2.4 -lsigc-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -ldl -lgthread-2.0 -lrt -lglib-2.0 '[/code]

Genete - The logo.sif file which the installer logo.sif uses does have a conical gradient (part of the sun texture). This gradient is of type ‘stripes’, and in my copy, the width value is 0.5 (for what it’s worth)

hbarnard - you listed inst*.* - can you also list logo.sif to show that it’s there?

You’re right, but that doesn’t explains why the width is missing. Maybe the file is corrupt?

[root@pepi images]# ls -al logo.sif -rw-r--r-- 1 1000 1000 105906 Jan 23 17:41 logo.sif

/me nods. Maybe it is corrupt.

Hi folks

Thanks for taking such a good interest in this. This is a big reason for me to ‘stay’ with synfig whenever I can get a working version sorted out. Just as a sideline question, what distro and version are you ‘mainly’ working with? Sooner or later, I’ll get a spare box!

If, in the meantime, there’s an answer to the *.sif thing, I’d be grateful and will carry on with this build.

Best regards Hugh

Any recent Debian or Ubuntu version would be fine. I still using Ubuntu Edgy (sigh*) and I can build it without any problem.
dooglus, our main developer, has made binaries for Feisty and Gusty and I think that also for Hardy for SVN versions. This one and last Debian stable have both our last release (0.61.08) included.

Check it in the Download area.


hbarnard, could you upload logo.sif and installer_logo.sif files here, please.
I’m using Fedora 7 now, but earlier used Fedora 6 and Fedora 4. I haven’t problems with compiling synfig.