Any chance for Synfig to stop lagging?


#1

Is there any way to fix lagging present in Synfig? For instance when moving an object or rotating it/zooming canvas


#2

Hi,
it would be helpful if you were adding some info here:

  • Synfig version (1.3.8 form me)
  • OS (Ubuntu 18.04 64bit for me)
  • GFX card drivers up-to-date?

According a previous post you are under Win 10.
Some recent updates of Win 10 and GFX drivers made it slower also
See forum.lazarus.freepascal.org/in … #msg285282 for example


#3

Thank you for an answer
I have 1.3.5 version of a Synfig.
Win10, and a laptop with Mobility Radeon 5850 2GB

Is it possible to get rid off lags in any way? I mean - does it in your setup, works well without it?


#4

Try to update to 1.3.8
Be sure your power profile uses 100% CPU and the laptop is power supplied
Check any possible trouble with drivers (GFX, Sound, Wireless, Hard Disk…), with a DPC Latency Checker if needed
Try to changer the Rendering Engine in the Preferences
Ensure Synfig uses your Radeon GFX card instead of the internal graphic card (I’ve got a Nvidia, I can choose per process)

Anyway Synfig redraws the full tree of Layers beeing modified, so you will always have a bit of lag :wink: