Animated gif problem

I am having a problem with Synfig. When I import an animated .gif image into it, it shows the new layer there, but it does not show the image itself. What can be the problem?

Thanks in advance.

Hmmm… It may be that the import code is not capable of handling animated gifs. I’d have thought that you would have got the first frame at least though.

Your best bet may be to use another program to seperate out the individual frames and import them into Synfig as a list. ImageMagick could probably do this for you (but I don’t know the syntax off the top of my head)


Well, I managed to separate the frames using Gimp, so hopefully that problem is solved now. I haven’t tried importing the individual frames into Synfig yet.
But now I have a new problem. I made a very short animation (just as kind of a test), with something visible for one frame, not visible for the next frame (4 f later), and visible again 4 f after the second frame. And then I tried rendering it in Synfig as a .gif file, but when I try to view it, its not animated! I opened it in Firefox, but the image stays still, and doesn’t disappear at all. Moreover, after that happened, I looked at the thing again in Synfig, and went to the second keyframe, where the image is supposed to be invisible, but the effect was apparently lost! The checkmarks by the image layers (which have a .png format) are checked again, though I clearly unchecked them on the second frame in animation mode. :open_mouth:

Any ideas?

BTW, when I viewed the rendered image in Firefox, it didn’t look so good. The edges were all ragged (which isn’t the case with the original thing). See the attached image to see what I’m talking about.

I guess Synfig doesn’t like the .gif format at all…

Which format do y’all use anyway when you create most animations? ffmpeg?

For good render result I strongly recommend export as png sequence.

This “checkmarcks by the image layers” sounds to me that you are trying to animate visibility of the layer using the enable/disable check mark. That’s not a animation parameter. It is part only of the GUI. Try to animate the Amount parameter of the layer by setting it to 0 in animation mode. Be sure that you have a keyframe on the frame 0 to keep the values of that frame intact.

Regarding to gif format, it is not guilty of your ragged effect. That effect comes from the image you provide to the program in the image layer. Try to use vectors to draw that ballom! forget image layers! you will have much more fun and the render result will be size independent! it will be always smooth!


As genete says, you can’t animate the appearance or disappearance of a layer with the check mark in the layer dialog. They just tell the renderer whether to render that layer or not (on or off for the whole animation). This makes it easy to, say, turn off the backgrounds for a quick test render… Animate the ‘amount’ parameter.

The other thing that always caught me out when I first started was to remember to click the green button to switch to animate mode (turns the green button red, and puts a red border around the canvas). I would leave it green and wonder why none of my changes ‘stuck’.

You might want to select gif rather than ‘auto’ with a gif filename when rendering. I seem to remember auto would result in a series of gif files rather than an animated gif. There may be some artifacts in the gif render too. I don’t think dooglus ever got to the bottom of those.