A couple of newbie questions

Hi all,

I just found Synfig and I’m excited to find out what it can do.
Upon first trying things out (such as the basic animation tutorial) I ran into a couple of questions that I can’t find the answer to in the help files / pages.
I’m using Synfig on a macbook running OSX Yosemite. I actually installed three versions of Synfig to test out: the OSX 64-bit installer on the main download page; the 64 bit OSX 0.65 dev snapshot and the the 64-bit OSX native version, both on SourceForge.
I have X11 and XCode installed.

The questions that I’m having are:

  • though only one of those packages is labeled as ‘native’, none of those three seem to be using X11? I do not see any X11 process running in any case, with none of those three versions. They also look quite similar on first sight: the only obvious difference is that the 0.64 version has a multi-pane layout, while both the ‘native’ version and the 0.65 develop snapshot are in single-window mode (as Gimp would call it).

  • I can find no single way to perform a right mouse click using the macbook trackpad. In Blender it’s cmd + click, but neither that nor any other combination of shift, ctrl, alt or cmd keys does the trick. Does anyone know how to fix this?

  • How can I delete an object? Say, the square that is created in that ‘Animation Basics’ tutorial with the Rectangle Tool?
    I downloaded the manual and searching for “remove” or “delete” results only in a description how to remove a vertex (accessed by right-clicking, unfortunately); but I cannot find how to remove a whole object. The menu neither contains any option to remove or delete a selected item.
    I suppose that I might miss something obvious, but I cannot think of what it might be … :open_mouth:

I’d appreciate any help!

I think that non native Synfig Stydio version needs to have XQuarz installed. That’s the difference.
For right click on trackpad I think you need to do a long touch with one finger or a single touch with two fingers to emulate right button. It is the same than the contextual menu un OS X.
To delete a shape select the shape and do this:
Right click and select Remove or
At the layers panel press the remove layer button. You can do that for all selected layers.

They’re really not the same :mrgreen:

I do have XQuartz installed. In fact, I can’t even remember installing it: it’s been on my machine for years because Gimp (and a couple of other apps like Kerkythea) used to require it.

However, it turns out that it is not launched - and hence, I figure, not needed - when I start either version of Synfig Studio.
Can’t it be that the version that’s labeled as ‘needing XQuartz’ might be misplaced in the download directory?
I’ll check again, but I am really quite sure that the version available here runs without XQuartz.

I’ve used OSX for about 10 years now, so I did figure out how to do a regular right click by now :wink: : the default is a control + click.
It is indeed possible to set the trackpad so that a tap acts as a click and a two finger tab acts as a right click. I tried, and indeed: this makes the context menu appear in Synfig.
But that’s not the default setting on OSX. The default is the control-click, and that doesn’t work.

I saw it when I experimented just now with the two finger tap gesture - so, every object has its own layer? I didn’t expect that because I’m used that ` layer can contain more than one item, but it does offer a workaround for now :smiley:

I know that an app running under xquartz isn’t the same thing as an app that doesn’t require xquartz.
I’ve seen the difference many times in several different applications, some in both versions.
I know when I’m looking at that difference - and I’m not looking at it now. Neither one has got the X11 system running; they look very similar.

The only major difference between those three versions is between the 0.64 and the 0.65 versions - not between the quartz and non-quartz versions. And that’s that the latter one runs in only one window, whereas the other one has multiple windows.

Here’s my recycle folder containing the downloaded packages and the Applications folder containing the Synfig .app files. From top to bottom: the regular 0.64 version, the one with quartz in its name and the 0.65 development snapshot - though they all seem to run fine without XQuartz / X11.

This is the 0.64 version’s ‘about’ screen:

and the 0.65 ‘quartz’ one:

and the 0.65 dev snapshot:

But anyhow, that doesn’t really matter - they run all fine - except, of course, that neither one reacts to the default right mouse click :unamused:

And another thing that puzzled me - the Linux version of Synfig is between 22 - 25 Mb; the Windows version about twice that size. But the OSX version is a whopping ten times as large - ~250 Mb - unpacked over a gigabyte. Why is that?

About Xquartz : Better crossplatfrom compatibility

0.65 is quite different from 0.64 series not only the single window thing, See the news from the last months, all them are included in 0.65 (formerly 1.0) and is not stably released yet.
-G

ah, I see.
I found another way of working around the right mouse click not working on the laptop touchpad - just assign one of the buttons in my tablet to a right mouse click event.

EDIT - I’ll see if there’s a way to help developing. I can in any case test OSX builds if there’s a need for that. While I am a developer, that’s mostly in the java /php etc area. so not sure if I could be of use here … my c++ is rather rusty.

Yes sure… test build are often putted here, building from MacOsX is scripted but i can’t talk more about it, you can see that with Yu / Jcome and Genete.

Php … hummm interesting, what do you think about helping us to clean the wiki from recurrent errors #1 #2 and/or (re)make the forum beautiful ?